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At this point the terms and concepts behind Eclipse plug-in development have been introduced. However, 
sometimes the best way to learn is by doing. In this laboratory exercise you will implement a Workbench 
action extension to contribute a menu item to the window menu bar that displays the message box, “Hello, 
Eclipse world.” While admittedly the final result is anticlimactic, it is definitely worth doing for the 
experience. You’ll have a chance to see how the different parts of the Plug-in Development Environment 
(PDE) work, and will also verify that your environment is correctly set up for your future plug-in 
development projects. 

At the end of this exercise you should be able to: 

• Create an XML manifest for a plug-in using the Plug-in Manifest Editor 
• Write the Java code to be executed for the extension 
• Test and debug your plug-in in the run-time Workbench 

In case you missed something, here’s an ultra mini-review. 

• A plug-in is an extension of the Eclipse Platform. It is a set of related files that implement 
some function and a manifest file, called plugin.xml, which describes the content of the 
plug-in and its configuration.  

• A plug-in can contribute to the Workbench by declaring an extension of an existing 
Workbench extension point. The manifest file describes this contribution. A plug-in 
can also declare new extension points that other plug-ins may use. That will be 
covered when we discuss Creating New Extension Points: How Others Can 
Extend Your Plug-in. 
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Exercise Setup 

The PDE Target Platform configuration adjustment made in this step ensures that all external plug-ins are 
visible. This configuration simplifies the plug-in development and is oriented towards new plug-in 
developers. Access the PDE Target Platform preferences using Window > Preferences. Expand Plug-In 
Development and select Target Platform. Select Not In Workspace to make all plug-ins visible, as shown 
in Figure 3.1. Select OK to close the dialog. 

 
Figure 1-1 
Making All External Plug-ins Visible  

 

Note: The number of plug-ins that can be selected depends on your version (2.0 or 2.1) and build (Eclipse 
vs WebSphere Studio Workbench). 

If you forget this step and continue creating a plug-in project using the PDE wizard, you will see the 
message shown in Figure 3.2. If you do see this message, it’s no problem. Just select OK to accept its 
resolution and continue. 
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Figure 1-2 
Wizard Warning Message  

Exercise Instructions 
You have a choice of how to complete this exercise. 

• The first approach uses the PDE’s plug-in project wizard to generate all the necessary 
code and the plug-in manifest details for an action extension. 
This first approach is presented in Section 1.  

• The second approach will proceed step-by-step, showing all the dialogs and editors that 
you need to use when creating a plug-in with the PDE. This approach offers you the 
chance to use the PDE when the example is quite simple, so you can concentrate on using 
the tool, not the details of the coding at hand.  
If you prefer this second approach, turn to Section 2. 

Reminder: Unlike some of the earlier exercises, this exercise has no template or solution 
associated with it. Once you have installed Eclipse and configured it as 
described above, you can start immediately. 

Section 1: “Hello, World” in Five Minutes or Less 

Eclipse should already be installed and open; you should have already completed the steps described in 
the “Exercise Setup” section.  

1. Begin by creating a plug-in project using the New Plug-in Project wizard. Select File > New > 
Project. In the New Project dialog, select Plug-in Development and then Plug-in Project in 
the list of wizards, and then select Next. Name the project com.ibm.lab.helloworld. Accept 
the default workspace location and select Next. The PDE will create a plug-in id based on this 
name, so it must be unique in the system (by convention, the project name and the plug-in id 
are the same). Accept the default plug-in project structure and select Next. Select the Hello, 
World option, as shown in Figure 3.3, and then select Next. 
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Figure 1-3 
Hello, World Plug-in Code Generator  
2. The proposed plug-in name and plug-in class name are based on the last word of the plug-in 

project, com.ibm.lab.helloworld. This example doesn’t need any of the plug-in class 
convenience methods, so deselect all three options under Plug-in code generation options, 
as shown in Figure 3.4, and select Next (not Finish; you’ve got one more page to go). 
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Figure 1-4 
Hello, World’s Simple Plug-in Content Wizard Page  
3. The next page, shown in Figure 3.5, is where you can specify parameters that are unique to 

the “Hello, World” example, such as the message that will be displayed. 
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Figure 1-5 
Hello, World Template Page  
4. To simplify the resulting code, change the target package name for the action from 

com.ibm.lab.helloworld.actions to com.ibm.lab.helloworld, the same package as 
that of the plug-in class. While you might choose to have a separate package for grouping 
related classes in a real-world plug-in, in this case there will only be two classes (the plug-in 
class and the action), so let’s put them together in the same package.  

5. Select Finish and continue with Section 3, Testing with the Run-Time Workbench. 

Section 2: “Hello, World” with Detailed Step-By-Step Instructions 

This approach to creating your first plug-in focuses on how to use the PDE, and thus omits some of the 
smaller implementation details. Rest assured, the exercises to follow cover them. That being said, let’s go! 

 Eclipse should already be installed and open; you should have already completed the steps described in 
the “Exercise Setup” section.  

1. Begin by creating a plug-in project using the New Plug-in Project wizard. Select File > New > 
Project. In the New Project dialog, select Plug-in Development and Plug-in Project in the 
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list of wizards, and then select Next. Name the project com.ibm.lab.helloworld. Accept the 
default workspace location and select Next. The PDE will create a plug-in id based on this 
name, so it must be unique in the system (by convention, the project name and the plug-in id 
are the same). Accept the proposed plug-in project structure and select Next. Select the 
Default Plug-In Structure option, as shown in Figure 3.6, and then select Next. 

 
Figure 1-6 
Default Plug-in Code Generator  
2. The proposed plug-in name and plug-in class name are based on the last word of the plug-in 

project, com.ibm.lab.helloworld. This example doesn’t need any of the plug-in class 
convenience methods, so deselect all three options under Plug-in code generation options, 
as shown in Figure 3.7, and select Finish. 
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Figure 1-7 
Simple Plug-in Content Wizard Page  

Note:  Although this example doesn’t need a plug-in class, deselecting the 
Generate code for the class option without clearing the Class name field 
generates a value for the class attribute of the <plugin> tag. In this 
case, the plug-in definition would reference a plug-in class that was not 
generated, resulting in a run-time error, Plug-in 
"com.ibm.lab.helloworld" activation failed while 
loading class "com.ibm.lab.helloworld.SampleAction" in 
the Console. For the sake of simplicity, let the wizard generate the plug-in 
class. 

The plugin.xml file generated should be automatically opened for editing using the 
Plug-in Manifest Editor in the PDE perspective after you select Finish, as shown Figure 
3.8. 
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Figure 1-8 
Welcome to Helloworld Plug-in  

You won’t see the Welcome page if you previously opened this project and selected Do 
not show this page the next time. In this case, you would see the Overview page 
instead. 

3. Select the Source page.  Verify that the generated plugin.xml content is as follows. 

<?xml version="1.0" encoding="UTF-8"?> 
<plugin 
   id="com.ibm.lab.helloworld" 
   name="Helloworld Plug-in" 
   version="1.0.0" 
   provider-name="IBM" 
   class="com.ibm.lab.helloworld.HelloworldPlugin"> 
 
   <runtime> 
      <library name="helloworld.jar"/> 
   </runtime> 
 
   <requires> 
      <import plugin="org.eclipse.core.resources"/> 
      <import plugin="org.eclipse.ui"/> 
   </requires> 
 
</plugin> 

Note that the <requires> section states that the basic user interface and core services 
must be present for this plug-in to load successfully.  



Extending Eclipse – First Plug-in 

Exercises © Copyright IBM Corporation 2000, 2002 1-10 

4. Select the Extensions page and select Add… to start the New Extension wizard (see Figure 
3.9). Select Generic Wizards and Schema-based Extension. This wizard will lead you 
through the creation of an extension based on the extension point’s schema definition, that is, 
based on its expected XML child tags and attributes. Select Next. 

 
Figure 1-9 
New Extension Wizard  
5. Select the org.eclipse.ui.actionSets extension point (see Figure 3.10). 
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Figure 1-10 
Extension Point Selection  

This extension point is used to add menus, menu items, and toolbar buttons to the 
common areas in the Workbench window. These contributions are collectively known as 
an action set and appear within the Workbench window menu or toolbar. Select Finish 
to create the new extension. 

 

6. There are very few extension points that do not require one or more child tags to complete the 
definition of the extension. In this particular case, the <actionSet> child tag must be added. 
Right-click on org.eclipse.ui.actionSets in the All Extensions list and select New > 
actionSet (see Figure 3.11). 



Extending Eclipse – First Plug-in 

Exercises © Copyright IBM Corporation 2000, 2002 1-12 

 

  
Figure 1-11 
Adding an Action Set  
7. Open the Properties view on the actionSet tag and set the id, label, and visible property 

values as shown in Figure 3.12. 

 
Figure 1-12 
actionSet Properties View  

Remember to press Enter after changing a property value; otherwise, the value may 
revert to its previous value when the Properties view loses the focus. 

The id is a required unique identifier that can be used as a reference to this action set. 
The visible attribute indicates whether the action set should be initially visible in all 
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perspectives. The XML code will create an action set called “Sample Action Set.” If you 
turn to the Source page, you will see the XML that you’ve created. 

<extension 
  point="org.eclipse.ui.actionSets"> 
    <actionSet 
      label="Sample Action Set" 
      visible="true" 
      id="com.ibm.lab.helloworld.actionSet"> 
    </actionSet> 
</extension> 

Note that the visible=true attribute is only honored when the user opens a new 
perspective that has not been customized. Selecting Window > Reset Perspective will 
show all action sets having the visible attribute set to true. 

8.  Now create a top-level menu. Right-click on the action set element and select New > menu 
(see Figure 3.13). 

 
Figure 1-13 
Creating a New Menu  

Open the Properties view on menu and set the label and id. The ampersand (&) in the 
value for the label indicates the next character, M, is a menu accelerator.  
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Figure 1-14 
Updating the New Menu’s Attributes  

When you turn to the Source page, this value is shown as &amp;, since the plug-in 
manifest is specified in XML, and that is the proper representation of an ampersand in 
XML. If you had entered it directly in the Source page as &, the manifest editor would 
detect an XML parsing error.  If forced into a plugin.xml file, Eclipse would detect the error 
during the XML parsing that ocurrs at startup. 

9. Now add a menu separator by right-clicking on the top-level menu and selecting New > 
separator (see Figure 3.15). 

 
Figure 1-15 
Adding a Menu Separator  

Actions are generally inserted into a menu relative to another item. Follow this convention 
by adding a separator that provides a placeholder for your action and other plug-in 
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developers that might want to contribute menu items. Contributors would do so by 
specifying the separator’s id in their action’s menubarPath or toolbarPath attribute. 

10.Change the separator’s name attribute to sampleGroup in its Properties view. Remember to 
press Enter while the Properties view entry has the focus to register the change.  

11.Now add a new action. You can do this by selecting actionSet in the All Extensions list as 
shown in Figure 3.16, and then select New > action. 

 
Figure 1-16 
Adding a New Action  

In the Properties view, set the action’s tooltip property value to Hello, Eclipse 
world, the id to com.ibm.lab.helloworld.SampleAction, and the label to &Sample 
Action. Then set menubarPath to sampleMenu/sampleGroup and toolbarPath to 
sampleGroup. These attributes are slash-delimited paths that are used to specify the 
location of the action in the menu. Also note that while it is more typical to add an action 
to either the window menu or the main toolbar, you can add them to both at the same 
time in a single <action> tag by specifying both the menubarPath and toolbarPath 
attributes. 

The action tag declares an action that will be available from the window menu and the 
main toolbar. When the user clicks on the action, the class referenced in the class 
attribute will be instantiated and its run method called.  
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12.Next you’ll code a simple action class that will display a message dialog. To create the action 
class, select the class attribute in the action’s Property view, then its “more” button (the 
button with the ellipsis next to the class attribute) to display the Java Attribute Editor, as 
shown in Figure 3.17. 

 
Figure 1-17 
Creating a Sample Action  

Select Generate a new Java class, accept the source folder name, and then enter the 
com.ibm.lab.helloworld package name (or use the Browse button) and the class 
name SampleAction.  

After these last two steps the following XML will be added to the manifest file, along with 
XML for the other entries you just created. 

<action 
  label="&amp;Sample Action" 
  class="com.ibm.lab.helloworld.SampleAction" 
  tooltip="Hello, Eclipse world" 
  menubarPath="sampleMenu/sampleGroup" 
  toolbarPath="sampleGroup" 
  id="com.ibm.lab.helloworld.SampleAction"> 

Then the class generator opens an editor on the source it created and adds a set of 
reminders to the Tasks view to implement your action (see Figure 3.18). 



Extending Eclipse – First Plug-in 

Exercises © Copyright IBM Corporation 2000, 2002 1-17 

 
Figure 1-18 
SampleAction Generated Code and Reminder  

13.Verify the plugin.xml in the Source page. It should look like this. 

<?xml version="1.0" encoding="UTF-8"?> 
<plugin 
   id="com.ibm.lab.helloworld" 
   name="Helloworld Plug-in" 
   version="1.0.0" 
   provider-name="IBM" 
   class="com.ibm.lab.helloworld.HelloworldPlugin"> 
 
   <runtime> 
      <library name="helloworld.jar"/> 
   </runtime> 
 
   <requires> 
      <import plugin="org.eclipse.core.resources"/> 
      <import plugin="org.eclipse.ui"/> 
   </requires> 
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   <extension 
         point="org.eclipse.ui.actionSets"> 
      <actionSet 
            label="Sample Action Set" 
            visible="true" 
            id="com.ibm.lab.helloworld.actionSet"> 
         <menu 
               label="Sample &amp;Menu" 
               id="sampleMenu"> 
            <separator 
                  name="sampleGroup"> 
            </separator> 
         </menu> 
         <action 
               label="&amp;Sample Action" 
               class="com.ibm.lab.helloworld.SampleAction" 
               tooltip="Hello, Eclipse world" 
               menubarPath="sampleMenu/sampleGroup" 
               toolbarPath="sampleGroup" 
               id="com.ibm.lab.helloworld.SampleAction"> 
         </action> 
      </actionSet> 
   </extension> 
 
</plugin> 

14.The plug-in manifest is complete. However, to make this result the same as generated by the 
PDE’s “Hello, World” example, you can add the following XML just above the closing 
</plugin> tag. 

<extension 
    point="org.eclipse.ui.perspectiveExtensions"> 
  <perspectiveExtension 
      targetID="org.eclipse.ui.resourcePerspective"> 
    <actionSet 
      id="com.ibm.lab.helloworld.actionSet"> 
    </actionSet> 
  </perspectiveExtension> 
</extension> 

This isn’t strictly required, but it’s a good idea. It adds the new action set to an existing 
perspective, so users doesn’t have to add it themselves with the Window > Customize 
Perspective… menu choice. The action set id above must match the action set id you 
specified earlier. 

Switch to the Source page and enter the new extension. When you turn back to the 
Extensions page, notice that the list is updated to include the modifications you made in 
the Source page, specifically, the addition of the 
org.eclipse.ui.perspectiveExtensions extension. The Plug-in Manifest Editor 
keeps page modifications synchronized, wherever they are entered. This comes in handy 
when you want to make a minor change. That is, you can modify an attribute directly in 
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the Source page instead of selecting the associated extension in the Extension page 
list and then modifying the attribute with the Properties view. 

15.Save the plugin.xml file.   
 

You can now finish the implementation of the action logic in the SampleAction class.  

16.Before an action’s run method is invoked, the Workbench first calls its init method, providing 
the current Workbench window. Some actions need to know the context in which they are 
invoked, so they start by saving a reference to the Workbench window. This requires that we 
add an instance variable declaration and logic to save the window reference. 

Add this instance variable to the SampleAction class: 

private IWorkbenchWindow window; 

Add this logic to the init method: 

this.window = window; 

17.The run method implements the action function. This action is simle, it will display your “Hello, 
Eclipse world” message. Add the code below to the action’s run method. 

public void run(IAction action) { 
  MessageDialog.openInformation( 
    window.getShell(), 
    "Helloworld Plug-in", 
    "Hello, Eclipse world"); 
} 

Notice that the editor indicates that a Quick Fix is available to correct the “undefined” 
MessageDialog class (see Figure 3.19). 

 
Figure 1-19 
Quick Fix Indicator  

Clicking the light bulb will propose several possible solutions.  Choose to import the 
missing class reference, and then save your modifications to SampleAction.java. 

You have just completed coding your first “Hello, World” plug-in, equivant to the one that you can create 
with the PDE’s Plug-in Code Generator. Continue with the next section to test it. 
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Section 3: Testing with the Run-Time Workbench 

You should have already completed Section 1, “‘Hello, World’ in Five Minutes or Less,” or Section 2, 
“‘Hello, World’ with Detailed Step-By-Step Instructions.” Whether you got here by taking the shortcut or the 
long way, you’re ready to test! 

1. Test your com.ibm.lab.helloworld plug-in by selecting the Run > Run As > Run-
time Workbench menu choice (if you don’t see this menu choice, verify that you’re in 
the Plug-in Development perspective and you have a plug-in project, folder, or file 
selected).  

After a few seconds, a second instance of the Workbench will open. If the Resource 
perspective is active, the Sample Menu pull-down should already be shown. 
However, in other perspectives, your action set must be explicitly added to the user 
interface. In that case, select the Window > Customize Perspective… menu choice. 
You should see your Sample Actions in the list under Other. Select your action set to 
add it, as shown in Figure 3.20.  

 
Figure 1-20 
Adding an Action Set to the Current Perspective 

You should see your addition in the Workbench menu bar. Note that the visible=true 
attribute of the <actionSet> tag is only honored when the user opens a new perspective 
that has not been customized. Selecting Window > Reset Perspective will show all 
action sets having the visible attribute set to true. 
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2. Select Sample Menu > Sample Action to display the message box (see Figure 3.21). 

 
Figure 1-21 
Hello, Eclipse World Message Box 
 

Note: If you chose the 5-minute approach, your UI will have a small round Eclipse image 
for the contributed tool bar action (shown in Figure 3.21). If you chose the detailed 
approach, you would not have specified an image so the Workbench will use a red 
square (default for missing images) to represent your action. 

3. Before you close the run-time instance of the Workbench, close the Welcome page. 
This will avoid the spurious version 2.0-only message “An error has occurred 
while restoring the workbench; See error log for more details.” Be sure 
to close the second instance of the Workbench. 

 

Congratulations, you have just created and tested your first plug-in for Eclipse! Now you are ready to try 
your hand at debugging a plug-in in the next section. If your plug-in didn’t work as expected, see the 
section “Correcting Common Problems” later in this exercise for help. 
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Section 4: Debugging with the Run-Time Workbench 

This section explores the tools the PDE has to help debug your plug-ins. You already have coded and 
tested your “Hello, Eclipse world” example, so how about intentionally introducing some bugs to see how 
they manifest themselves? The short debug session that follows is an example of how to find plug-in specific 
errors. Begin by verifying that you’ve closed the run-time Workbench from the prior section, and then 
return to the Plug-in Development perspective of your Eclipse development environment. Next, open your 
plug-in’s manifest file. 

1. Turn to the Source page and introduce an error in the class attribute of the <action> 
tag. 

<action 
  label="&amp;Sample Action" 
  class="com.ibm.lab.hello.SampleAction"  <!-- error, was "helloworld" --> 
  tooltip="Hello, Eclipse world" 
  menubarPath="sampleMenu/sampleGroup" 
  toolbarPath="sampleGroup" 
  id="com.ibm.lab.helloworld.SampleAction"> 
</action> 

When you launch the run-time Workbench and select Sample Action, a dialog is 
displayed that indicates that the chosen operation is not currently available, and a 
message is displayed in the Console of your development Workbench, as shown in 
Figure 3.22. 

 
Figure 1-22 
Console Error Message  

That is, messages in the run-time instance to System.out and System.err are 
redirected to the Console in the development Workbench. Before closing the run-time 
instance, open the Plug-in Registry view (Window > Show View > Other... > PDE 
Runtime > Plug-in Registry) and scroll down to your plug-in, as shown in Figure 3.23. 
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Figure 1-23 
Plug-in Registry  

From here you can see precisely what was parsed from your plugin.xml file, similar to 
the Outline view of the plug-in manifest, but available at runtime. Close the run-time 
Workbench. 

2. Correct the error from the prior step (e.g., by selecting plugin.xml, and then Replace 
With > Previous From Local History). Now let’s introduce a more serious error. 
Comment out the code below from SampleAction. 

 public void init(IWorkbenchWindow window) { 
//  this.window = window; 
 } 

This change will provoke a null pointer exception in the run method. Save the change 
and relaunch the run-time Workbench, this time using the Run > Debug As > Run-time 
Workbench menu choice. Notice that the perspective automatically changes to the 
Debug perspective. 

3. Again select the Sample Action menu choice. Nothing appears to happen. No 
message from the run-time instance, so look in the Console of the development 
Workbench. As expected, the message Unhandled exception caught in event 
loop. Reason: java.lang.NullPointerException is displayed. To get more 
details, go back to the run-time instance of the Workbench and open the plug-in Error 
Log (Window > Show View > Other... PDE Runtime > Error Log). Indeed, there 
are two new entries. Double-click the java.lang.NullPointerException message 
and select Status Details, as shown in Figure 3.24. 
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Figure 1-24 
Error Status Details 

At this point in a real debug session you might consider setting an exception breakpoint 
for NullPointerException from the J! button on the Breakpoints page to further 
diagnose the problem. Don’t set such an exception breakpoint before launching the 
Workbench; it will stop in a lot of places that have nothing to do with your problem. 
Instead, set and then disable the exception you want to debug before starting the 
Workbench, then enable it when you’re ready to reproduce the problem. 

4. Close the run-time instance before continuing. 
This short debug session gives you a flavor of debugging plug-ins. As you create your own plug-ins, 

you’ll find more difficult problems that this one. When that happens, refer to the section “Correcting 
Common Problems” later in this exercise. 

Section 5: Exploring (and Sometimes Correcting) the Eclipse Platform 
Code 

One of the benefits of an open source project is the fact that the source is yours to study, and if 
necessary, correct. Let’s see how the PDE helps you to learn and modify Eclipse code. 

You have already been introduced to the notion of “external” versus “workspace” plug-ins; the Target 
Platform preference page, shown back in Figure 3.1, allows you to add external plug-ins to the list of those 
available in the test environment and your plug-in’s build path. But what if you want to modify the code 
found in an external plug-in to help you debug or to correct a bug in the Eclipse code? The PDE includes 
options in the Plug-in view that makes it easy, as shown in Figure 3.25. 
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Figure 1-25 
Import External Plug-in As Source Project  

To get a better idea of how this works, let’s import one of the Eclipse plug-ins and add some debug code. 

1. If you haven’t closed the run-time instance of Eclipse, do so now. Then turn to the Plug-
ins view as shown in Figure 3.25, select the org.eclipse.core.resources plug-in, 
and then select Import > As Source Project. This will copy the plug-in from the 
plugins directory to your workspace, including its source, and recompile it. After 
recompiling, you’ll notice quite a few errors in the Tasks view, such as “The project 
was not built since it is involved in a cycle or has classpath problems” and “Missing 
required Java project.” This is because the original Eclipse plug-ins were built in a 
single workspace, while yours has some plug-ins in your workspace and others in the 
plugins subdirectory. Turn to the Package Explorer view, select the project, select 
Update Classpath… from its pop-up menu, and then select Finish in the dialog. This 
will recalculate the project’s build (class) path based on your configuration and 
recompile, correcting the above errors. 

2. Repeat the procedures in step 1 for the org.eclipse.core.runtime plug-in, but this 
time select Import > As Binary Project instead. After updating the classpath, look at 
both projects in the Package Explorer view. Notice that the source importation results 
in Java source files available in the src-resources folder on the left, and Java class 
files in the runtime.jar file on the right, as shown in Figure 3.26. 
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Figure 1-26 
Import External Plug-in Results  

Both projects are now in your workspace, and therefore are included in all workspace 
searches, but the org.eclipse.core.resources plug-in can be modified as well. If you 
turn back to the Plug-ins view, note that the project icon has changed from an external 
plug-in ( ) to a folder, indicating that it is now in your workspace. 

3. To see an example of how you might use this to help your debugging, let’s assume that 
you want to know more about what resources (projects, files, and folders) are created 
and when. Begin by opening the class the represents them, Resource, in the package 
org.eclipse.core.internal.resources by selecting Navigate > Open Type… or 
pressing Ctrl+Shift+T (more than one matching package is shown in the Open Type 
dialog; choose the one located at /org.eclipse.core.resources/src-resources). 
Add a debug System.out.println statement in the constructor, as shown below. 

protected Resource(IPath path, Workspace workspace) { 
 this.path = path.removeTrailingSeparator(); 
 this.workspace = workspace; 
  
  // Debug code. 
 System.out.println 
   ("Created resource " + path + " in workspace " + workspace); 
} 

This will generate output to the Console whenever a new resource is created. 
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4. Launch the run-time Workbench. You should see the warning shown in Figure 3.27, 
since the two plug-ins that you imported are in the workspace and are also specified in 
the Plug-in Development > Target Platform preference page as external plug-ins. 

 
Figure 1-27 
Duplicate Plug-ins Warning  

If you want to avoid this warning, go back to this preference page and select Not in 
Workspace. That will automatically deselect the two plug-ins that you imported. Verify 
that your debug code shows its output in the Console by creating a new project, folder, 
and file. 
This short example demonstrates how you can add debug code, and how you could also apply your own 

fixes to Eclipse Platform code, should the need present itself. 
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Section 6: Correcting Common Problems 

Table 3.1 lists some of the more common errors you might encounter when writing your first few plug-ins, 
their symptoms, and possible resolutions. If you don’t find the problem you’re seeing in this table, follow the 
“Hints and Tips” link from the readme.html on the CD-ROM included with this book, which has more 
suggestions. If you are still stuck, consider posting a message to the eclipse.org newsgroups. 

Table 1.1 Common Errors and Possible Resolutions 
Symptom Source Possible Resolution 
“Plug-ins required to compile Java classes in 
this plug-in are currently disabled. The wizard 
must enable them to avoid compile errors.” 

Warning message 
dialog when creating 
new project 

Accept the suggested action. This is equivalent to 
selecting Not in Workspace in Preferences > 
Plug-In Development > Target Platform. 

“The project was not built since it is 
involved in a cycle or has classpath 
problems,” or one of several errors similar 
to “Missing required Java project: 
org.eclipse.xxx.” 

Tasks view Verify manifest is not missing required plug-ins in the 
<import> statements of the <runtime> tag. Verify 
that required plug-ins are either imported into 
workspace or available from the Preferences > 
Plug-In Development > Target Platform list. Then 
select Update Classpath... for the affected project. 

 

For Eclipse version 2.0 only: This suggested 
correction might not work if the project was created 
before setting the external plug-ins on the Target 
Platform page. An easy, albeit dramatic, workaround 
is to start with a fresh workspace, remembering to 
set the external plug-ins first. 

“This compilation unit indirectly references 
the missing type java.lang.Object (typically 
some required class file is referencing a 
type outside the classpath)” or “This 
plug-in contains unresolved and/or cyclical 
references to other plug-ins.” 

Tasks view and 
Overview page of 
Plug-in Manifest 
Editor 

Project build path is incorrect. The PDE will 
automatically update the build path of plug-ins when 
the <requires> tag is modified, unless the 
Preferences > Plug-In Development > Java 
Build Path Control options are deselected. Verify 
and try Update Classpath... for the affected project. 
If this doesn’t correct the errors, manually add the 
required plug-ins from the project’s Properties > 
Java Build Path > Library > Add Variable dialog. 
Select ECLIPSE_HOME and add the required plug-in 
JAR files by selecting the Extend... button. 

“The list of plug-ins to run contains 
duplicates. Plug-ins from the workspace 
will be used. To fix the problem, uncheck 
the offending external plug-ins in the 
Preferences or Launch Configurations.” 

Warning message 
dialog when 
attempting to start 
run-time 
Workbench 

There are one or more plug-ins that are present in 
the workspace and in the Preferences > Plug-In 
Development > Target Platform list or the Plug-in 
and Fragments page of the launch configuration 
(Run... or Debug...). This often occurs after: 

§ Importing a plug-in into the workspace with 
Import > External Plug-ins and Fragment or 
one of the Plug-ins view’s Import menu choices 

§ Copying a plug-in that exists in the workspace to 
the plugins directory  

§ Or installing a feature that references plug-ins 
that exist in the workspace  

Either close the project of the duplicate plug-in in the 
workspace so it will be ignored, or deselect the 
appropriate external plug-in in the list, as the 
message suggests. 
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“Exception launching the Eclipse Platform” 
followed by a long exception trace. 

Error Log or 
Console 

Check if the run-time Workbench is already running. 
If this is the case, you will see this message at the 
bottom of the exception trace, “The platform 
metadata area is already in use by another platform 
instance, or there was a failure in deleting the old 
lock file.  If no other platform instances are running, 
delete the lock file and try starting the platform again.” 
This can occur after the Workbench abnormally 
terminates. Verify that the run-time Workbench is 
closed, or if it is already terminated, manually delete 
the .lock file. 

Contributed action is not present. Run-time 
Workbench 

Verify the id attributes of your actions–there may be 
a duplicate. The actions are stored in a keyed table, 
so duplicate entries are lost. 

Contributed pull-down menu is disabled or 
contributed action is not present. 

Console Verify the menubarPath attribute. Look in the Console 
for the message “Invalid Menu Extension (Path is 
invalid).” Check the spelling, especially if the word 
“separator” is in the menu path. Many programmers 
misspell this word. Consider using “groupXXX.” 

“The chosen operation is not currently 
available.” is displayed after selecting a 
contributed action. 

Run-time 
Workbench 

There are several possibilities. 

§ Check the Console. If it contains the error 
message, “Could not create action. Reason: 
Plug-in xxx was unable to load class yyy,” where 
“xxx” is your plug-in and “yyy” is your action 
class, verify that your specification of the 
action’s class attribute is correct, the code 
compiled correctly, and there are no build path 
errors associated with your plug-in. 

§ Check the enablement specification of your 
action; it may be inconsistent with the 
enablement logic of your action’s 
selectionChanged method. For example, your 
action’s XML specifies the action is available 
only if the selection is an IFile with extension 
.java, but the action’s selectionChanged 
method checks for an IFile with the extension 
.class. The static enablement logic of your 
action and its dynamic logic must be consistent. 

“An error has occurred while restoring the 
workbench; See error log for more 
details.” is displayed and “Unable to 
restore editor - createElement returned 
null for input element factory: 
org.eclipse.ui.internal.dialogs.WelcomeEdi
torInputFactory” is shown in Console. 

Error message 
dialog when 
launching run-time 
Workbench 

A harmless message in the version 2.0 Workbench 
that you can safely ignore (it has since been 
corrected). Closing the Welcome  page of the run-
time Workbench will avoid the message. 

 

Don’t be intimidated by the number of entries in this table. It includes problems that are not very likely for 
your “Hello, World” exercise, but they may prove helpful should you decide to experiment beyond the 
instructions in this exercise. 
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Exercise Activity Review 

In this exercise you used the PDE to create, test, and debug a plug-in. You now have the basics of writing, 
testing, and debugging a plug-in. Return to Part II where you left off— it will lead you further in your study 
of the Eclipse extension points and frameworks that you can employ to enhance the Workbench’s 
capabilities.  
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Introduction 

This exercise will show you how to use some of the SWT controls. 

Skill Development Goals 

At the end of this lab, you should have a general understanding of how to create a user interface with 
SWT and understand their event handling. 

Exercise Setup 

Setup tasks must be complete before you begin the exercise. 

A PDE project has been set-up for you named com.ibm.lab.swt. We will use a view as a container 
for our SWT widgets. You may not be familiar with programming views yet, so a plug-in containing an 
empty view and view class has been defined for you. 

 

Load the project com.ibm.lab.swt into your workspace. 
 

Note: You can use code snippets from the SWTView.jpage file included in the exercise template to save 
you from having to retype them. 
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Exercise Instructions 

Part 1: Use buttons to invoke the FileDialog and the MessageDialog 

 
1. Add the SelectionListener interface to the class as defined below  

 

public class SWTView extends ViewPart implements SelectionListener{ 
// … code … 
} 

To clear up any compile problems use the editor context menu called Source > Organize Imports or 
Add Import (Ctrl+Shift+M). You will need to use this feature frequently in the lab. 
 

Select the class in the outline view and from the context menu, select Source > 
Override/Implement Methods... to generate the required methods of the interface. See Figure 
2-1. You should add all the methods that the ISelectionListener interface defines, although 
for the moment we are only interested in the widgetSelected method. 

 

 
Figure 2-1 
Method override selection dialog [swt_01.tif] 

 
Note: The added method stubs are added but not compiled. You must save the file 
SWTView.java to compile them.  
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2. Add the following field to the class: 
 

private Shell workbenchShell; 
 

3. The createPartControl method will accept the creation of widgets. Add the following 
statement: 
 

workbenchShell =  
  PlatformUI.getWorkbench().getActiveWorkbenchWindow().getShell(); 

 
We will need access the workbench shell as a parameter in the FileDialog class later in the 
exercise. The static method getWorkbench in the PlatformUI class provides a link to the 
shell. The createPartControl method passes a Composite object (representing our view 
container). This Composite object is the parent to all the widgets that we will be creating.  

Create a method with the following signature: 
 

 
void open(Composite parent) {} 

 
The Composite object comes from createPartControl and is our reference to the view 
container. 
 
Add the following statements to the open method in order to provide a layout manager for our 
controls. This defines a single column grid layout. 
    

 
parent.setLayout(new org.eclipse.swt.layout.GridLayout()); 
parent.setLayoutData(new GridData(GridData.GRAB_VERTICAL)); 

 
4. Invoke this method at the end of the createPartControl method: 

 
open(parent); 

5. Create a method void createButtons(Composite parent). In this method, create a 
group to hold the pushbuttons. Make sure that you have set the layout information for your 
group, otherwise your buttons will not be visible. Add two push buttons to the group. The first 
button should have the text, “Show Messagebox”. The second button should have the text, 
“Show File Dialog”.   
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Group group = new Group(parent, SWT.NONE); 
group.setLayout(new GridLayout()); 
group.setText("Buttons"); 
group.setLayoutData 
  (new GridData(GridData.GRAB_HORIZONTAL | GridData.HORIZONTAL_ALIGN_FILL)); 
Button b1 = new Button(group, SWT.PUSH); 
b1.setText("Show Messagebox"); 
b1.setFocus(); 
Button b2 = new Button(group, SWT.PUSH); 
b2.setText("Show File Dialog"); 

 
6. In the open method, call createButtons. Add these statements to the end of the open 

method. 
 

new Label(parent, SWT.NONE); //vertical spacer 
createButtons(parent); 

 
7. Since we want the SWTView class to be notified when the button has been pressed, we need to 

add this class as a SelectionListener for the button. Use the addSelectionListener 
method and pass in this as the parameter. Add the following line of code (bold) to the 
createButtons method after b1.setFocus.  
 

 
Button b1 = new Button(group, SWT.PUSH); 
b1.setText("Show Messagebox"); 
b1.setFocus(); 
b1.addSelectionListener(this); 

 
8. This listener interface requires you to implement two methods:  

• void widgetSelected(SelectionEvent e)  
• void widgetDefaultSelected(SelectionEvent e) 

These methods were generated earlier. You just have to fill in the body of the method. When the button 
is selected, a message dialog will be displayed. We must add the following code to the 
widgetSelected method. The other method is ignored since we don’t care about a default selection 
on a button. The first parameter we are passing is a null instance of a Shell object, which is 
unnecessary in this instance. 

MessageDialog.openInformation( 
  null, 
  "SWTView", 
  "Hello World! "); 
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9. When button b2 is selected, we will display a FileDialog with the style set to SWT.OPEN. 
Print the filename selected to the console. Just for variety, use an anonymous inner class to 
implement the widgetSelected method. Modify the createButtons method by adding 
the code below after b2.setText("Show File Dialog"). Note that FileDialog does 
require a Shell object as the first parameter. 

 

b2.addSelectionListener(new SelectionAdapter() { 
  public void widgetSelected(SelectionEvent e) { 
    FileDialog dialog = new FileDialog(workbenchShell, SWT.OPEN); 
    dialog.setFilterExtensions(new String[] { "*.jar;*.zip" }); 
    String selectedFile = dialog.open(); 
    System.out.println("The file you chose is " + selectedFile); 
 } 
}); 

10.Test your application by starting up your test workbench from this PDE project. Open view 
Lab: SWT > Lab: SWT Lab (use Window > Show View > Other…). You can double 
click on the view title bar so that the view is the only visible frame (double clicking again 
returns to multi-frame mode). It should look like Figure 2-2.  

 

 
Figure 2-2 
SWT Lab Panel [swt_02.tif] 
 
Press the Show Messagebox button to see a message pop-up. Press the Show File Dialog 
button and select a file. Look at the Console view in the development workbench instance to see 
the file selected. 

Part 2: Add StyledText 
 

1. StyledText is class that supports many attributes of what is commonly known as “rich text”. For 
instance, you can set color and font of a StyledText field. 
 

Add a private field in the SWTView class of type StyledText. 
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private StyledText myText; 

 
2. Create a method called createStyledText(Composite parent) and put the text control 

in its own group box. Set the initial text to “abcdefg”. 

public void createStyledText(Composite parent) { 
  new Label(parent, SWT.NONE); //vertical spacer 
  Group group2 = new Group(parent, SWT.NULL); 
  group2.setLayout(new GridLayout()); 
  group2.setText("Styled Text"); 
  group2.setLayoutData( 
    new GridData(GridData.GRAB_HORIZONTAL | GridData.HORIZONTAL_ALIGN_FILL)); 
  new Label(parent, SWT.NONE); 
  myText = new StyledText(group2, SWT.SINGLE|SWT.BORDER); 
  myText.setText("abcdefg"); 
} 

 
3. In the open method, add the call to createStyledText. Insert it at the end of the method. 

new Label(parent, SWT.NONE); //vertical spacer 
createStyledText(parent); 

 
4. Add the code to change the text when the button, b1, is pressed. Modify the 

widgetSelected(SelectionEvent) method to set the text to “Hello World” after the 
message dialog is displayed. The line of code to add at the end of the method is: 

myText.setText("Hello World"); 
 

 
5. To learn about another listener interface, add a ModifyListener to the end of the 

createStyledText method. The method you need to implement for this interface is void 
modifyText(ModifyEvent e). To see when this event is being generated, print a message 
“Got new text” to the console when you receive the event. Set the size and redraw the text 
when you get this event.  
 

myText.addModifyListener(new ModifyListener() { 
  public void modifyText(ModifyEvent e) { 
    myText.setSize(90,25); 
    System.out.println("Got new text"); 
  } 
}); 



SWT 
  

Copyright IBM Corporation 2000, 2002 2-7 

 
6. Let’s observe another listener. Also add a ControlListener to the code in 

createStyledText.  Implement the void controlResized(ControlEvent e) 
method. Print out a message stating that the control has been resized. 
 

myText.addControlListener(new ControlListener() { 
  public void controlResized(ControlEvent e) { 
    System.out.println("Control Resized"); 
  } 
  public void controlMoved(ControlEvent e) {} 
}); 

 
7. Before we finish let’s assign a font to this StyledText widget to illustrate widget disposal. A 

Font object must be disposed since it does not directly belong to the widget hierarchy of the 
view (the parent Composite object in this case).  
 

a. Add the font to the class:  
 

 
private Font font; 

Update the createStyledText method to assign a bold, Courier font to the myText field. 
 

font = new Font(myText.getDisplay(), new FontData("Courier",14,SWT.BOLD)); 
myText.setFont (font); 

Lastly, we want to dispose of the font. We will override the dispose method of the view so that when it 
gets disposed, the font does, too. Select the class in the outline view and select Override Methods in 
its context menu. In the dialog, select the class WorkbenchPart then dispose. The method will be 
added to your code. Add this line of code to the dispose method. 
 

 
font.dispose(); 

Set a breakpoint on this line. The class FontRegistry is something you might want to investigate if 
you are using many fonts. It handles disposal for you. 
 

8. Test your application using the debugger. You should see a view like Figure 2-3. Click on the 
buttons and look at the Console view in the development Workbench instance to see the results 
of your code. Close the view. Did you stop at your breakpoint? Reopen the view and then close 
your test instance of the workbench. Did you stop at your breakpoint again? 
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Figure 2-3 
SWT lab panel [swt_03.tif] 

 

Part 3: Add a List 

1. Go to the class definition and add a static array of strings. The following code should be added to the 
class definition. 

static String[] ListData1 = 
  {"Sherry", "Scott", "Dan", "Jim", "Pat", "John", "The Longest String"}; 

 
2. Create the createList method. 

 

 
public void createList(Composite parent) {} 

 
3. In the createList method, create a List and use the styles to specify that you want to be 

able to scroll and have multiple selections. 

List myList = 
  new List (parent, SWT.V_SCROLL | SWT.H_SCROLL | SWT.MULTI | SWT.BORDER); 
myList.setLayoutData(new GridData()); 

    
4. Use the static array, ListData1, to initialize the contents of the list. Add the following code to 

the end of the createList method. 

 
myList.setItems (ListData1); 
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5. Use SelectionListener to be notified when an element in the list is selected. Add this to 
the end of createList. 
  

myList.addSelectionListener( 
  new SelectionListener() { 
    public void widgetSelected(SelectionEvent e) { 
      System.out.println("List item selected"); 
    } 
    public void widgetDefaultSelected(SelectionEvent e) { 
       System.out.println("List item default selected"); 
    } 
  } 
); 

 
6. Update the open method to invoke the createList method. 

new Label(parent, SWT.NONE); //vertical spacer 
createList(parent); 

Test your application. Notice that you only receive one event on a multiple select. You should 
see a window like Figure 2-4: 

 
Figure 2-4 
SWT lab panel [swt_04.tif] 

Part 4: Thread Synchronization (optional) 

You will run the solution com.ibm.lab.soln.swt. Make sure it is available and open in 
your workspace. The solution has one more function that demonstrates synchronization 
between the Workbench running in the SWT UI thread and another thread.  
1. Select the project and start a test instance of Eclipse using menu Run > Run As > Run-time 

Workbench. 
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2. From the test instance of Eclipse, open the Soln: SWT Lab view. Open it using Window > Show 
View > Other… > Soln: SWT > Soln: SWT Lab. Expand the view and press the Fill Progress 
Bar button. The Display.asyncExec method updates the progress bar from the user thread. The 
Display.syncExec method displays the dialog half way through the process. The code is in 
SWTView.createProgressBar method. Information is written to the Console view of the Eclipse 
host instance during this operation. 
 

Exercise Activity Review 

What you did in this exercise: 

• Used SWT controls to create a simple user interface 
• Experimented with SWT event handling 
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This exercise takes you through the process of defining a simple wizard to understand the basics, and then 
converting the wizard so it creates a project with customized content.  

Introduction 

Wizards are useful user interface components in the Eclipse workbench. Your tool may just choose to 
define wizards that are associated to one of the wizard extension points defined by the platform or also use 
wizards in other places in your tool.  
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Exercise Concepts 

The exercise begins with a plug-in project as generated by the PDE, with the addition of one action 
extension, which will be used to show how you can open a wizard directly. 

You will begin by building a simple wizard, test it, and then use the action provided to open it directly. test 
this existing code, then build a JFace component that includes a viewer, content provider, and label 
provider. This implementation will expose a portion of the viewer API so that the JFace component can 
accept an input, add selection change listeners, use a predefined table in the viewer, and allow alternate 
content provider and label provider implementations to be identified. 

Skill Development Goals 
This exercise looks at the definition and use of Wizards so that you can understand:  

• How wizards and wizards pages are defined 
• How you can open a wizard directly 
• Where wizards exist when defined as part of a platform extension point 
• How you can build on the existing wizard and wizard page framework in Eclipse 

Exercise Setup  
Before you can begin this exercise, you must have access to the com.ibm.lab.newWizard template 
plug-in project. This project should already have been imported into your workspace. If not, import the plug-
in from the exercise templates location on your workstation. 

Primary Exercise Instructions 

The goal is to implement a wizard that creates a new project. At this point the project will not have any 
special attributes (such as a project nature), but it will be created such that it does have a predefined folder 
which contains two files. One file created with dynamic content and one created based on the content of a 
file in the plug-in’s runtime/install directory. The process of getting there will include the definition of a 
simple wizard and opening the wizard directly in a menu action. 

Part 1: Implement A Simple Wizard 
The first task is to define and create a simple wizard. First, you add the extension definition, and then you 
create a wizard class by letting it be generated by the PDE. 

Step 1. Define New Wizard Extension  
Edit the plugin.xml and add the view extension, this includes a category for the view (how it will be found in 
the Show View dialog) and the view itself. 
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1. Edit the plugin.xml file in the com.ibm.lab.newWizard project you imported earlier. Select 
the Extensions tab. You will now specify the information needed for the View extension. 

2. Define the wizard extension.  

Select the Add… button. Select Generic Wizards > Schema-based Extensions. 
Press Next. Scroll down the list, select the extension point for new wizards, 
org.eclipse.ui.newWizards, and Press Finish.  

3. Specify the category for this new wizard. 

Select the org.eclipse.ui.newWizards entry in the extensions list and press Finish. 
Choose the New > Category context menu. Using the Properties view, modify the id 
for the category to be com.ibm.lab.newWizard.category and the name for the 
category to be Edu: Wizards. The parent category will be blank.  

4. Define the new wizard 

Select the org.eclipse.ui.newWizards entry in the extensions list and choose the 
New > Wizard context menu.  

Using the Properties View, specify the following: 

• category: com.ibm.lab.newWizard.category 
• icon:  icons\CustomNature.gif 
• id:    com.ibm.lab.newWizard.wizard  
• name:   Edu: Custom Project 
• project:  true 

Ignore the class property for now; you will specify a value later. 

5. Save the plugin.xml file. The XML for the new wizard should look like this in the Source 
page: 

<extension 
      point="org.eclipse.ui.newWizards"> 
   <category 
         name="Edu: Wizards" 
         id="com.ibm.lab.newWizard.category"> 
   </category> 
   <wizard 
         name="Edu: Custom Project" 
         icon="icons\CustomNature.gif" 
         category="com.ibm.lab.newWizard.category" 
         class="com.ibm.lab.newWizard.NewWizard1" 
         project="true" 
         id="com.ibm.lab.newWizard.wizard"> 
   </wizard> 
</extension> 

Step 2. Generate Wizard  
The PDE can generate classes for many extension types. You will now use the PDE to generate a class for 
your wizard. 
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1. Return to the extensions page of the plugin.xml file to generate the wizard class using the 
PDE and select the Edu: Custom Project (wizard) entry in the list.  

2. In the Properties View, generate the class by selecting the continuation entry (...) in the class 
field.  

In the Java Attribute Editor, specify that you want to generate a new Java class. The 
class name is CustomProjectWizard and you want to let the wizard (see, you can 
use them anywhere) open an editor on the class after it is created. Leave the source 
folder and package name at their default settings. 

3. Select Finish to generate the class. 

When complete, the Java Attribute Editor (which is also a wizard) will open an editor 
open on the CustomProjectWizard class. The required init()and 
performFinish() methods were generated by the Java Attribute Editor wizard.  

4. Save the plugin.xml file. 

Step 3. Define a Wizard Page and Add it to the Wizard  
The wizard is a controller for the wizard pages it will display. You need at least one wizard page before you 
have a user interface for the wizard. 

1. Use the new class wizard to create a new class in the existing package. When creating the 
class you should:  

• Name it CustomProjectFilePage 
• Extend org.eclipse.jface.wizard.WizardPage 
• Select “Constructors from the superclass” 
• Select “Inherited abstract methods”  

Select Finish to generate the class. 

When complete the wizard will open an editor open on the CustomProjectFilePage 
class. The wizard generated the required createControl() method and two 
constructors.  



New Project Wizard 

Exercises © Copyright IBM Corporation 2000, 2003 3-5 

2. Define the user interface for the wizard page by adding these two fields to the class and 
making these changes to the createControl() method: 

public Button loggingFile; 
public Button readmeFile; 
… 
public void createControl(Composite parent) { 
  // Build page ui 
  Composite pageui = new Composite(parent, SWT.NONE); 
  FillLayout fillLayout = new FillLayout(); 
  fillLayout.type = SWT.VERTICAL; 
  pageui.setLayout(fillLayout); 
  setControl(pageui); 
 
  // populate pageui with required controls 
  Composite buttonui = new Composite(pageui, SWT.NONE); 
  RowLayout rowLayout = new RowLayout(); 
  rowLayout.type = SWT.VERTICAL; 
  buttonui.setLayout(rowLayout); 
 
  loggingFile = new Button(buttonui, SWT.CHECK); 
  loggingFile.setText("Create change log file"); 
  loggingFile.setSelection(true); 
 
  readmeFile = new Button(buttonui, SWT.CHECK); 
  readmeFile.setText("Create readme file");   
  readmeFile.setSelection(true); 
} 

Note: Copy the method above from the JPages\Part1_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s), be sure to choose the org.eclipse.swt.widgets.Button import. 

3. Add the wizard page to the wizard by adding a field and the addPages() method to the 
CustomProjectWizard class. This field and method logic should be added: 

private CustomProjectFilePage filePage; 
… 
public void addPages() { 
  filePage = 
    new CustomProjectFilePage("filePage", "Generated Project Files", null); 
  filePage.setDescription("Select the files to be added to the project."); 
  addPage(filePage); 
} 

Note: Copy the logic above from the JPages\Part1_Wizard.jpage file. 
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4. Customize the performFinish() method in the CustomProjectWizard class so that it 
returns true and allows the wizard to close after the Finish button is pressed. The method 
logic should also indicate what options were chosen on the wizard page. 

Make the performFinish() method look like this: 

public boolean performFinish() { 
 // Identify choices made on the filePage 
 boolean log = filePage.loggingFile.getSelection(); 
 boolean readme = filePage.readmeFile.getSelection(); 
 
 // Show choices from filePage 
 MessageDialog.openInformation( 
  null, 
  "File Selections Made", 
  "Logging file is " + log + "\n Readme file is " + readme); 
  return true; 
} 

Note: Copy the method above from the JPages\Part1_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s) and then save the Java source. 

5. Launch the runtime workbench to test the wizard user interface.  

Open the New dialog: File > New > Project…and then select Edu: Wizards > 
Edu: Custom Project. Then click Next to enter the wizard.  

You should see a wizard page that looks like this: 

 
Figure 3-1 
CustomProjectFilePage Displayed in CustomProject  
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You now have a working wizard. If you select one or both toggles and then click on 
Finish you will be told what was selected and the wizard will close. 

Close the runtime workbench after testing is complete. 

Step 4. Open the Wizard from an Action  
You defined a wizard by extension, but if your wizard class just extended Wizard and implemented the 
IWizard interface, you could use your wizard anywhere. An action contribution extension and the 
associated class have been defined for you in the template project. You can customize this action to open 
the wizard you just defined. 

1. Modify the run() method in the OpenWizardAction class so that the action will open the 
wizard you just defined. Modify the run() logic to look like this: 

public void run(IAction action) { 
  Shell shell =  
    PlatformUI.getWorkbench().getActiveWorkbenchWindow().getShell(); 
 
  // Create the wizard 
  CustomProjectWizard wizard = new CustomProjectWizard(); 
 
  // Create the dialog to wrap the wizard 
  WizardDialog dialog = new WizardDialog(shell, wizard); 
 
  dialog.open(); 
} 

Note: Copy the method above from the JPages\Part1_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s) and then save the Java source. 

2.  Launch the runtime workbench to test the wizard user interface.  

Open the wizard using the Edu: Actions > Open Wizard menu option. If this option is 
not visible, reset the perspective (Window > Reset Perspective).  

You should see a wizard page that looks just like the one shown earlier. 
 

You have now defined a working wizard, and seen how the workbench will find an open a wizard defined as 
an extension. You have also learned how you can open your own wizards from anywhere you might need 
one in your tool.  
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Part 2: Revise the Wizard so that it Adds a New Project to the Workspace  
The current wizard just shows one wizard page and reports selection status. The goal is to create a wizard 
that will create a new project and customize the project with files in a predefined folder.  

You will begin by modifying the existing wizard so that it incorporates the existing new project wizard 
function provided by the platform and customizing it to include the wizard page already defined with control 
logic that actually adds files to the project once it has been created. 

Step 1. Add the Reusable New Project Wizard Page to your Wizard  
The platform provides reusable wizard pages. You will add the reusable wizard page that supports the 
creation of a basic project to your wizard. This same page is seen when you use the existing function 
found in the user interface (New > Project… > Simple > Project). 

1. Start by adjusting the addPages() method in the CustomProjectWizard class. It must add 
the projectPage before the filePage, and to ensure that the filePage is visited, its page 
complete state must be set to false.  

Add the field shown and modify the addPages() method so that it looks like this: 

private WizardNewProjectCreationPage projectPage; 
… 
public void addPages() { 
 
  projectPage = new WizardNewProjectCreationPage("projectPage"); 
  projectPage.setTitle("Create a New Project"); 
  projectPage.setDescription( 
    "Enter name and optional custom location for a project"); 
  addPage(projectPage); 
 
  filePage = 
    new CustomProjectFilePage("filePage", "Generated Project Files", null); 
  filePage.setDescription("Select the files to be added to the project."); 
  filePage.setPageComplete(false); 
  addPage(filePage); 
} 

Note: Copy the logic above from the JPages\Part2_Wizard.jpage file. 

2. Once the filePage has been visited, the page complete state needs set to true so the wizard 
can be finished. Override the inherited setVisible() method by adding this method to the 
CustomProjectFilePage class: 

public void setVisible(boolean visible) { 
 super.setVisible(visible); 
 setPageComplete(true); 
} 

Note: Copy the method above from the JPages\Part2_Wizard.jpage file. 
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3. Launch the runtime workbench to test the wizard user interface.  

Open the New dialog: File > New > Project…and then select the Edu: Wizards in the 
left column and then Edu: Custom Project in the right. Then click Next to enter the 
wizard.  

The new first page of the wizard looks like this: 

 
Figure 3-2 
Custom New Project Wizard  

You now have a working multi-page wizard. The Finish button will not be enabled until 
you visit the last page (filePage). When you do press Finish, a message dialog will 
be shown, but that is all. The logic to create and then customize the project has not 
been integrated.  

Close the runtime workbench after testing is complete. 

Step 2. Implement Create New Project Wizard Finish Logic 
The wizard first needs to create a project using the values defined on the projectPage.  

1. In the CustomProjectWizard class, select these statements in the performFinish() 
method: 

 // Show choices from filePage 
 MessageDialog.openInformation( 
  null, 
  "File Selections Made", 
  "Logging file is " + log + "\n Readme file is " + readme); 

Once the statements have been selected use the Refactor > Extract method… 
context menu option to create a new method. Name the new method 
customizeProject().  
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The extracted method should look like this: 

private void customizeProject(boolean log, boolean readme) { 
  // Show choices from filePage 
  MessageDialog.openInformation( 
    null, 
    "File Selections Made", 
    "Logging file is " + log + "\n Readme file is " + readme); 
} 

2. Adjust the performFinish() method so that it first obtains the project and project location 
reference from the projectPage and then invokes a new method, createProject(), with 
these values passed as parameters to actually create the project. The createProject() 
method does not exist yet, so ignore the associated compile error. The customizeProject() 
method (created in the previous task) is invoked if the project exists. 

The modified performFinish() method should look like this: 

public boolean performFinish() { 
 
 // Get project from projectPage 
 final IProject newProject = projectPage.getProjectHandle(); 
   
 // Get project location as required 
 final IPath projectLoc = getProjectLocation(); 
 
 // Identify choices made on the filePage 
 boolean log = filePage.loggingFile.getSelection(); 
 boolean readme = filePage.readmeFile.getSelection(); 
 
  // Create project using custom location if provided 
  createProject(newProject, projectLoc); 
 
  // If project exists, customize it   
  if (newProject.exists())  
    customizeProject(log, readme); 
       
  //    If project exists, return true, if not return false  
  if (newProject.exists()) 
    return true; 
  else 
    return false; 
} 

Note: Copy the method above from the JPages\Part2_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s).   
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3. Use the quick fix support (Ctrl+1 while the cursor is on the createProject() error marker) to 
create a method named createProject(). Once done, you need to customize the method so 
it creates a project.  

This requires that you first create a project description. The description defines the 
project location using either the default file system location (project folder is in the 
workspace directory) or using the location value that was defined on the 
projectPage. The project is then created using the description and then opened.  

The completed createProject() method should look like this: 

private void createProject(IProject newProject, IPath projectLoc) { 
 
  // Create project description 
  IProjectDescription projectDesc = 
   NewWizardPlugin.getWorkspace().newProjectDescription(newProject.getName()); 
 
  projectDesc.setLocation(projectLoc); 
 
  // Create project 
  try { 
    newProject.create(projectDesc, null); 
    newProject.open(null); 
 
  } catch (CoreException e) { 
    // Auto-generated catch block 
    e.printStackTrace(); 
  } 
} 

Note: Copy the method above from the JPages\Part2_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s) and then save the Java source. 

4. Launch the runtime workbench to test the wizard logic.  

Open the New dialog: File > New > Project…and then select the Edu: Wizards in the 
left column and then Edu: Custom Project in the right. Then click Next to enter the first 
wizard page, the projectPage (the field name in the addPages() method). 

Enter a project name, optionally a location other than the default, click Next to enter 
the filePage, and then Finish. The logic added to the method will add a new project 
to the workspace. 

Close the runtime workbench after testing is complete. 
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Step 3. Implement Create Folder and Files Wizard Finish Logic 
The wizard now creates a project, but you still need to have it react to the choices made on the filePage 
and create the required folder and requested files. The folder will always be created while file creation will 
depend on the selections made on the filePage.  

1. Customize the signature and logic for the existing customizeProject() method so that it 
looks like this:  

private void customizeProject(IProject project, boolean log, boolean readme) { 
 
  // Create Folder 
  IFolder readmeFolder = ProjectCustomizer.createFolder(project, "readme"); 
 
  // Create Logging File (if required) 
  if (log) 
    ProjectCustomizer.createChangeLogFile(project, "Change_log.txt"); 
 
  // Create Readme File from template (if required) 
  if (readme) { 
    IPath template = new Path("readme_template/readme_file_template.readme"); 
    String fileName = project.getName() + ".readme"; 
    ProjectCustomizer.copyTemplate(readmeFolder, fileName, template); 
  } 
 
} 

Note: Copy the method above from the JPages\Part3_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s). When prompted, select the org.eclpise.core.runtime.Path option. 
You will correct the compile error in the next task. 

The ProjectCustomizer class was provided in the template project. Review the 
methods in this class to see how the project reference and passed parameters are 
used to create the required resources. A folder, two files, and a bookmark marker are 
created if you select both options.  

Note: One of the files that are created comes from a file in the plug-in’s source 
directory. Can you tell which one? 

2. Adjust the invocation of the customizeProject() method in the performFinish() method 
to add the newProject parameter which was added to the method signature. 

3. Launch the runtime workbench to test the modified wizard finish logic.  

Enter a project name, and then go to the end and select Finish. The project should be 
created and customized based on the selected options on the filePage. The new 
project should look something like this in the Navigator view: 
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Figure 3-3 
Structure of Customized Project  

Close the runtime workbench after testing is complete. 

You are done with the basics. If you have time, or want to return here later, you can do 
the optional portion of this exercise. 

Optional Exercise Instructions 

The optional portion of this exercise allows you to learn more about how to manage resource events (so 
you have a well performing plug-in), provide task feedback using the wizard monitor, and may the flow 
of the wizard dynamic. 

Optional Part 1: Adjust the Project Customization Process to Limit Resource Events 

The wizard you defined creates a project and customizes it as required. It works, and 
this is not bad, but it can be better.   

How?  Put your performance hat on. Remember the discussion about resource change 
events? Each resource creation or modification action in the createProject() and 
customizeProject() methods triggers a resource change event. Let’s start by 
looking at this in a bit more detail. 
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Step 1. Trace the Resource Change Events Triggered by the Wizard 
A resource change listener has been provided as part of the project template. By enabling this listener, it 
will report changes that have occurred as messages in the console log. 

1. Change the NewWizardPlugin class so that the provided resource change listener is added 
when the plug-in starts. Modify the startup() method; uncomment the addRCL() method 
invocation: 

public void startup() throws CoreException { 
  // Let super do the normal startup work 
  super.startup(); 
  // The resource change listener will be added if/when this method is invoked 
  addRCL(); 
} 

2. Test the new code by starting the runtime workbench and creating a new custom project. 

The resource change listener that was provided will print information about each 
resource event that occurs to the Console view. The following would be listed for the 
creation of the customized project: 

RCE: 1 
RCE: 1 -> Event triggered... 
RCE: 1 -> Resource has been changed. 
RCE: 1 ->   Resource / has changed. 
RCE: 1 ->   Resource /custom.project was added. 
RCE: 1 ->   Resource /custom.project/.project was added. 
RCE: 2 
RCE: 2 -> Event triggered... 
RCE: 2 -> Resource has been changed. 
RCE: 2 ->   Resource / has changed. 
RCE: 2 ->   Resource /custom.project has changed. 
RCE: 2 ->  ResourceDelta Kind: Opened 
RCE: 3 
RCE: 3 -> Event triggered... 
RCE: 3 -> Resource has been changed. 
RCE: 3 ->   Resource / has changed. 
RCE: 3 ->   Resource /custom.project has changed. 
RCE: 3 ->   Resource /custom.project/readme was added. 
RCE: 4 
RCE: 4 -> Event triggered... 
RCE: 4 -> Resource has been changed. 
RCE: 4 ->   Resource / has changed. 
RCE: 4 ->   Resource /custom.project has changed. 
RCE: 4 ->   Resource /custom.project/Change_log.txt was added. 
RCE: 5 
RCE: 5 -> Event triggered... 
RCE: 5 -> Resource has been changed. 
RCE: 5 ->   Resource / has changed. 
RCE: 5 ->   Resource /custom.project has changed. 
RCE: 5 ->   Resource /custom.project/Change_log.txt has changed. 
RCE: 5 ->   ResourceDelta Kind: Marker Change 
RCE: 5 ->      Marker delta kind: Added 
RCE: 5 ->      Marker type: org.eclipse.core.resources.bookmark 
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RCE: 6 
RCE: 6 -> Event triggered... 
RCE: 6 -> Resource has been changed. 
RCE: 6 ->   Resource / has changed. 
RCE: 6 ->   Resource /custom.project has changed. 
RCE: 6 ->   Resource /custom.project/Change_log.txt has changed. 
RCE: 6 ->   ResourceDelta Kind: Marker Change 
RCE: 6 ->      Marker delta kind: Changed 
RCE: 6 ->      Marker type: org.eclipse.core.resources.bookmark 
RCE: 6 ->      Marker content: [1] 
RCE: 7 
RCE: 7 -> Event triggered... 
RCE: 7 -> Resource has been changed. 
RCE: 7 ->   Resource / has changed. 
RCE: 7 ->   Resource /custom.project has changed. 
RCE: 7 ->   Resource /custom.project/Change_log.txt has changed. 
RCE: 7 ->   ResourceDelta Kind: Marker Change 
RCE: 7 ->      Marker delta kind: Changed 
RCE: 7 ->      Marker type: org.eclipse.core.resources.bookmark 
RCE: 7 ->      Marker content: [1, 10] 
RCE: 8 
RCE: 8 -> Event triggered... 
RCE: 8 -> Resource has been changed. 
RCE: 8 ->   Resource / has changed. 
RCE: 8 ->   Resource /custom.project has changed. 
RCE: 8 ->   Resource /custom.project/Change_log.txt has changed. 
RCE: 8 ->   ResourceDelta Kind: Marker Change 
RCE: 8 ->      Marker delta kind: Changed 
RCE: 8 ->      Marker type: org.eclipse.core.resources.bookmark 
RCE: 8 ->      Marker content: [11, 10, 1] 
RCE: 9 
RCE: 9 -> Event triggered... 
RCE: 9 -> Resource has been changed. 
RCE: 9 ->   Resource / has changed. 
RCE: 9 ->   Resource /custom.project has changed. 
RCE: 9 ->   Resource /custom.project/Change_log.txt has changed. 
RCE: 9 ->   ResourceDelta Kind: Marker Change 
RCE: 9 ->      Marker delta kind: Changed 
RCE: 9 ->      Marker type: org.eclipse.core.resources.bookmark 
RCE: 9 ->      Marker content: [custom.project: Change Log File, 11, 1, 10] 
RCE: 10 
RCE: 10 -> Event triggered... 
RCE: 10 -> Resource has been changed. 
RCE: 10 ->   Resource / has changed. 
RCE: 10 ->   Resource /custom.project has changed. 
RCE: 10 ->   Resource /custom.project/readme has changed. 
RCE: 10 ->   Resource /custom.project/readme/custom.project.readme was added. 

The first two events (RCE:1-2), are the creation and opening of the project. All the rest 
are the creation of the folder (RCE:3), Change_log.txt file(RCE:4), Change_log.txt file 
marker(RCE:5), marker attributes(RCE:6-9), and the .readme file(RCE:10). The 
interesting thing is that the custom.project project resource and associated 
.project file were created as part of one event. The rest of the project customization 
should also take place as part of that same event if you want a better performing tool. 
There is no reason to fire ten events when one will do. 
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Step 2. Wrap Wizard Resource Creation in a Runnable 
There are several options for how to wrap a set of workspace operations to limit the number of resource 
change events. The workspace can process an object that implements the IWorkspaceRunnable 
interface using the workspace.run() method.  

When performing workspace updates from a user interface you may also want to consider the use of the 
WorkspaceModifyOperation class. This class allows you to construct a runnable that has access to a 
progress monitor. A progress monitor can be obtained from the wizard container. 

1. Create a WorkspaceModifyOperation structure that can be used to wrap the resource 
creation and modification logic in a runnable. The goal is an inner class with an execute() 
method that performs project creation and customization. You could just copy this from the 
JPage file, but for fun why not let the Eclipse JDT do most of the work.  

Make these edits to the performFinish() method: 

• Add a few empty lines before the invocation of the createProject() method. 
• Enter this text, Workspacem, and then press Ctrl+Space to trigger code completion. 

Choose the option WorkspaceModifyOperation 
• Enter op = new  on the same line and then press Ctrl+Space and again choose the 

WorkspaceModifyOperation option. 
• Enter a left parenthesis (the JDT will generate the match) and then press Ctrl+Space 

again. The JDT will open a dialog to help you complete the WorkspaceModifyOperation 
inner class definition. 

• The default selection (execute() method) is fine so just select OK. 
• Enter a semi-colon (;) to complete the generated statement, the cursor should already be 

in the correct location. 

That should be all you need. The completed statement should now look like this: 

WorkspaceModifyOperation op = new WorkspaceModifyOperation() { 
  protected void execute(IProgressMonitor monitor) 
    throws CoreException, InvocationTargetException, InterruptedException { 
    // TODO Auto-generated method stub 
 
  } 
}; 

This can now be used to create and customize the project. 

2. Cusomize the WorkspaceModifyOperation structure so that it creates and customized the 
project.   

Move most of the first part of the existing performFinish() logic to the execute() 
method (the newProject variable stays outside). The WorkspaceModifyOperation 
structure should now look like this: 
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WorkspaceModifyOperation op = new WorkspaceModifyOperation() { 
    protected void execute(IProgressMonitor monitor) 
      throws CoreException, InvocationTargetException, InterruptedException { 
 
      // Get project location as required 
      IPath projectLoc = null; 
      if (!projectPage.useDefaults()) 
      projectLoc = projectPage.getLocationPath(); 
      
      // Identify choices made on the filePage 
      boolean log = filePage.loggingFile.getSelection(); 
      boolean readme = filePage.readmeFile.getSelection(); 
 
      // Create project using custom location if provided 
      createProject(newProject, projectLoc); 
 
      // If project exists, customize it   
      if (newProject.exists()) 
        customizeProject(newProject, log, readme); 
    } 
};  

3. Correct the error related to the newProject variable. Use the Quick Fix function (put cursor on 
field reference and press Ctrl+1 or click on the light-bulb icon) to change the newProject 
variable definition to final. 

Other errors will still exist, which is fine for now. 

4. Add logic to the performFinish() method to actually run the WorkspaceModifyOperation. 
This logic should go after the WorkspaceModifyOperation structure but before the last if 
statement: 

try { 
  op.run(null); 
} catch (InvocationTargetException e) { 
  e.printStackTrace(); 
} catch (InterruptedException e) { 
  e.printStackTrace(); 
} 

Note: Copy the logic above from the JPages\Xtra_Part1_Wizard.jpage file. 

The run() method takes the operation and passes it on to the workspace for 
processing. 

5. Launch the runtime workbench to test the modified wizard finish logic.  

Enter a project name, and then go to the end and select Finish. The project should be 
created and customized based on the selected options on the filePage. If you were to 
peek at the resource change events that were triggered you would see a different 
scenario: 
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RCE: 1 -> Event triggered... 
RCE: 1 -> Resource has been changed. 
RCE: 1 ->   Resource / has changed. 
RCE: 1 ->   Resource /custom.project was added. 
RCE: 1 ->   ResourceDelta Kind: Opened 
RCE: 1 ->   Resource /custom.project/.project was added. 
RCE: 1 ->   Resource /custom.project/Change_log.txt was added. 
RCE: 1 ->   ResourceDelta Kind: Marker Change 
RCE: 1 ->      Marker delta kind: Added 
RCE: 1 ->      Marker type: org.eclipse.core.resources.bookmark 
RCE: 1 ->      Marker content: [custom.project: Change Log File, 11, 1, 10] 
RCE: 1 ->   Resource /custom.project/readme was added. 
RCE: 1 ->   Resource /custom.project/readme/custom.project.readme was added. 

This is much better, the creation and customization of the project is now just one 
complex event.  

Optional Part 2: Run the WorkspaceModifyOperation with a Monitor 
When you directly run the operation you passed a null monitor in the run() method. It might be nice to 
have a monitor so that you could show progress through the operation and possibly support a cancel 
request if this was truly a long-running activity. You will add support for a monitor, but we will not worry 
about a cancel request. 

Step 1. Provide a Monitor to the WorkspaceModifyOperation Instance 
You can use the wizard framework to run this operation and reuse the monitor available in the wizard. 

1. Customize the invocation of the operation to let the wizard (actually, the container for the 
wizard) invoke the runnable. 

In the performFinish() method, replace this statement: 
  op.run(null); 

With this statement: 
  getContainer().run(false, false, op); 

The operation will be invoked, but now it will have access to a monitor (as opposed to 
a null) in the operation’s run() method because you are now using the wizard dialog 
to run the operation. 

The Wizard getContainer().run() method allows you to choose if the operation 
should be run on a new thread (where UI widgets would not be visible) and if it can be 
canceled. Ultimately, the operation is passed on to the workspace for processing.  

Note: If you changed the run() method so that the code wrapped in a 
WorkspaceModifyOperation was not running on the UI thread (run(true, false, 
op)) there would be no direct access to the SWT widgets. You would have to move 
this logic out of the execute() method logic for the operation and make the variables 
final. 

You can now customize the logic used to create and customize the project to actually 
accept and use the monitor during the required processing steps. 
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2. Modify the CustomProjectWizard init() method so that it contains this logic: 

public void init(IWorkbench workbench, IStructuredSelection selection) { 
  setNeedsProgressMonitor(true); 
} 

This is required to tell the wizard container that you want to see (and use) the progress 
monitor as part of the wizard dialog. 

3. Modify the WorkspaceModifyOperation defined in the performFinish() method to initialize 
the task being monitored and pass the monitor instance to the createProject() and 
customizeProject() methods. The revised execute() method logic should look like this: 

protected void execute(IProgressMonitor monitor) 
  throws CoreException, InvocationTargetException, InterruptedException { 
 
  monitor.beginTask("Create Customized Project:", 3000); 
  monitor.subTask("prepare"); 
 
  // Get project location as required 
  IPath projectLoc = null; 
  if (!projectPage.useDefaults()) 
     projectLoc = projectPage.getLocationPath(); 
      
  // Identify choices made on the filePage 
  boolean log = filePage.loggingFile.getSelection(); 
  boolean readme = filePage.readmeFile.getSelection(); 
 
  monitor.worked(1000); 
  ProjectCustomizer.pause(1000); 
 
  // Create project using custom location if provided 
  createProject(newProject, projectLoc,  
    new SubProgressMonitor(monitor, 1000)); 
 
  // If project exists, customize it 
  if (newProject.exists()) { 
     monitor.subTask("customize"); 
     ProjectCustomizer.pause(1000); 
     customizeProject(newProject, log, readme, 
       new SubProgressMonitor(monitor, 1000)); 
  }  
  monitor.done(); 
} 

Note: Copy the method above from the JPages\Xtra_Part2_Wizard.jpage file. 

The use of the ProjectCustomizer.pause() method slows down the processing so 
you can actually see the progress bar in the wizard react to the monitor logic during 
testing. 
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4. Modify the createProject(…) method signature to accept the monitor and the logic to use it 
during project creation. The modified method should look like this: 

private void createProject(IProject newProject, IPath projectLoc, 
    IProgressMonitor monitor) { 
 
  monitor.beginTask("", 500); 
  monitor.subTask("create project description"); 
 
  // Create project description 
  IProjectDescription projectDesc = 
   NewWizardPlugin.getWorkspace().newProjectDescription(newProject.getName()); 
  projectDesc.setLocation(projectLoc); 
 
  monitor.worked(100); 
  ProjectCustomizer.pause(1000); 
 
  // Create project 
 
  try { 
    monitor.subTask("create project"); 
    newProject.create(projectDesc, monitor); 
    monitor.worked(100); 
    ProjectCustomizer.pause(1000); 
 
    monitor.subTask("open the new project"); 
    newProject.open(monitor); 
    monitor.worked(100); 
    ProjectCustomizer.pause(1000); 
 
    monitor.done(); 
 
  } catch (CoreException e) { 
    // Auto-generated catch block 
    e.printStackTrace(); 
  } 
} 

Note: Copy the method above from the JPages\Xtra_Part2_Wizard.jpage file. 
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5. Modify the customizeProject(…) method signature to accept the monitor and the logic to 
use it during project creation. The modified method should look like this: 

private void customizeProject(IProject project,  boolean log, boolean readme, 
   IProgressMonitor monitor) { 
 
  monitor.beginTask("", 3000); 
 
  // Create Folder 
  monitor.subTask("add folder"); 
  IFolder readmeFolder = ProjectCustomizer.createFolder(project, "readme"); 
 
  monitor.worked(1000); 
  ProjectCustomizer.pause(1000); 
 
  // Create Logging File (if required) 
  monitor.subTask("add log file"); 
  if (log) 
    ProjectCustomizer.createChangeLogFile(project, "Change_log.txt"); 
 
  monitor.worked(1000); 
  ProjectCustomizer.pause(1000); 
 
  //  Create Readme File from template (if required) 
  monitor.subTask("add readme file"); 
  if (readme) { 
    IPath template = new Path("readme_template/readme_file_template.readme"); 
    String fileName = project.getName() + ".readme"; 
    ProjectCustomizer.copyTemplate(readmeFolder, fileName, template); 
  } 
 
  monitor.worked(1000); 
  ProjectCustomizer.pause(1000); 
 
  monitor.done(); 
} 

Note: Copy the method above from the JPages\Xtra_Part2_Wizard.jpage file. 

6. Launch the runtime workbench to test the modified wizard finish logic.  

Enter a project name, and then go to the end and select Finish. The project should be 
created and customized based on the selected options on the filePage. The f you 
were to peek at the resource change events that were triggered you would see a much 
better scenario: 
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Figure 3-4 
Wizard with Progress Monitor Bar  

Close the runtime workbench after testing is complete.  

Optional Part 3: Make the Customize Project Page and Processing Optional 
The wizard you defined creates a project and customizes it as requested. If you want to make visiting the 
customization page optional, including the act of customization itself, then you need to change the wizard 
structure and add support for a dynamically defined page. This requires that you add a user interface 
control to the new project page to allow the user to determine if they want a customized project and adds 
the required page to the wizard flow if it was requested. 

Step 1. Create a Customized Version of the New Project Page  
The first step is to create a new project page that lets the user determine if they want to customize the 
project at the same time. Wizard pages such as the new project page, are both reusable and customizable. 

1. Create a new class, CustomWizardNewProjectCreationPage, that extends the existing 
page. When you create this new class: 

• Extend WizardNewProjectCreationPage 

• Select the “Constructors from superclass” option 
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2. Override the createControl() method to add another widget to the user interface. If you 
begin typing in the class and enter createc and then press Ctrl+Space, you will have the 
option of generating the method stub. 

To add a toggle to the existing new project page by adding a field and customizing the 
method. The new code should look like this: 

public Button needFilePage; 
… 
public void createControl(Composite parent) { 
  // Allow superclass to create user interface 
  super.createControl(parent); 
 
  //  Additional UI controls added to control defined by super 
  Composite pageui = (Composite) getControl(); 
 
  // Add required controls to existing control 
  Composite buttonui = new Composite(pageui, SWT.NONE); 
  RowLayout rowLayout = new RowLayout(); 
  rowLayout.type = SWT.VERTICAL; 
  buttonui.setLayout(rowLayout); 
 
  needFilePage = new Button(buttonui, SWT.CHECK); 
  needFilePage.setText("Customize Project"); 
  needFilePage.setSelection(true); 
} 

Note: Copy the logic above from the JPages\Xtra_Part3_Wizard.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s). Make sure you choose the SWT options when presented. 

3. Adjust the wizard to reference the new customized new project page. This requires changes to 
the projectPage field and addPages() logic. Change WizardNewProjectCreationPage 
references to CustomWizardNewProjectCreationPage. Use the Source > Organize 
Imports option (Ctrl+Shift+O) to adjust the required import statement(s). 

Step 2. Add the Customized Project Page On Request 
Instead of adding the customizing page automatically in the wizard addPages() method you need to have 
a user control that determines when it should be added and logic that supports the request. 

1. The wizard needs changed to allow access to the filePage field. Generate a getter method 
for this filed by selecting the field in the Outline view and using the Source > Generate 
Getter and Setter… context menu option. Add only the getter method. 
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2. Add logic to the toggle button in the new project page user interface so it can determine if the 
customization page must be shown as part of the wizard.  

The following logic should be added to the createControl() method, after the 
needFilePage.setSelection(true); statement, in the 
CustomWizardNewProjectCreationPage class: 

 needFilePage.addSelectionListener(new SelectionAdapter() { 
   public void widgetSelected(SelectionEvent event) { 
     CustomProjectWizard wizard = (CustomProjectWizard) getWizard(); 
 
     if (needFilePage.getSelection()) 
       wizard.getFilePage().setPageComplete(false); 
     else 
       wizard.getFilePage().setPageComplete(true); 
 
     getContainer().updateButtons(); 
   } 
 }); 

This logic sets the filePage completion status based on the needFilePage selection. 
The filePage status was initialized to false as the needFilePage toggle was 
initialized to true. The wizard is then told to update the Next and Finish buttons so they 
reflect the need for a second page. 

If you tested the wizard now you would be able to deselect the Customize Project 
option and then click Finish on the first wizard page. The project would still be 
customized at creation as the performFinish() method doesn’t yet care about this 
selection. 

3. Adjust the performFinish() logic in the CustomProjectWizard so that project 
customization is only performed when requested. The modified logic references the selection 
state before invoking the customizeProject() method: 

  // If project exists, customize it 
  if (newProject.exists() && projectPage.needFilePage.getSelection()) { 
    monitor.subTask("customize"); 
    ProjectCustomizer.pause(1000); 
    customizeProject(newProject,  log, readme, 
      new SubProgressMonitor(monitor, 1000)); 
  } 

4. Launch the runtime workbench to test the modified wizard finish logic.  

The new project page now has a toggle which determines if the second wizard page 
must be visited (page complete state) and if the project should be customized: 
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Figure 3-5 
Wizard with Customization Toggle  

Close the runtime workbench after testing is complete.  

Step 3. Adjust Page Processing to Reflect the Need for the Customization Page 
If the customizing page is optional, then it should not be part of the wizard. The page is added to the wizard 
in the addPages() method, but this does not mean it must exist in the flow of wizard processing. Since it 
has already been added, you will now just ignore it when appropriate by providing a customized 
getNextPage() method in the custom new project page. 

1. Override the getNextPage() method in the CustomWizardNewProjectCreationPage class. 
The completed method should look like this: 

public IWizardPage getNextPage() { 
  if (needFilePage.getSelection())  
    return super.getNextPage(); 
  else 
    return null; 
} 

The typical getNextPage() method just asks the wizard for the next page (see the 
implementation in the WizardPage class. This logic only allows this to occur if the next 
page is required. 

2. Launch the runtime workbench to test the modified wizard finish logic.  

Now when you deselect the new project page toggle the Next button is disabled as 
there is no next page (a null was returned by getNextPage()): 
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Figure 3-6 
Wizard with Customization Toggle and Page Control Logic 

Close the runtime workbench after testing is complete.   

Exercise Activity Review 

What you did in this exercise: 

• Learned how to define a new wizard extension and generate a wizard class 
• Implemented a wizard page with a customized user interface 
• Extended a platform wizard, the new project wizard, to include your wizard page 
• Extended the wizard finish logic to include the project customization processing 
• Wrapped the project customization logic in a WorkspaceModifyOperation to manage the 

number of resource change events that are generated. 
• Integrated the monitor provided by the wizard container with the 

WorkspaceModifyOperation  
• Modified the reusable new project wizard page to customize the user interface 
• Created a dynamic wizard by controlling wizard page progression based on user 

interaction. 
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Introduction 

This exercise guides you through the process of using the dialog support in the Workbench 
to create value management pages for Preference values. 

Exercise Concepts 

During this exercise, you will implement one or more of the following: 

• Plug-in definitions that support preference page extensions to the workbench. 
• Persistence of data values using a preference store. 
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Skill Development Goals 

At the end of this exercise, you should be able to: 

• Add preference page extensions to a plug-in 
• Define and implement a plug-in class 
• Create a preference page that can save values 

Exercise Setup 

These setup tasks are required before you can begin this exercise: 

• Setup the Workbench so that all external plugins are visible to support plugin development and 
testing. 

• Import the com.ibm.lab.dialogs project to your workspace. 

Note:  You may have already performed these setup activities. 

The dialogs lab template provides you with a starter plug-in (EDU Dialogs) and a base set 
of code, but the implementation of some code components is incomplete. You get to add 
new methods and references to other methods not yet invoked by the base code.  

The com.ibm.lab.dialogs project contains the following files: 

• Plugin.xml – a starter file to help you create the desired plug-in. 
• getstart_b.gif – a graphic file that will be referenced by the plug-in manifest file. 
• A set of Java scrapbook pages, organized by class, which contain code fragments referenced in this 

lab. You can use these to minimize the need to retype code defined in this document.  
• Partially coded classes that will be completed during the lab.  
• EDU_plugin.xml – plug-in definitions that you can reuse during the lab. 

Other files, such as .classpath and .cvsignore, which are not used in this exercise. 

Exercise Instructions 

Part 1: Preference page definition 

A preference page dialog is started using the Window  > Preferences menu option available 
on the Workbench window. A plug-in can define any number of preference pages. The 
pages can be organized as a related set such that they share a navigation tree in the 
common preferences dialog window. 

Step 1: Add preference page extensions 

You will define an extension for a preference page that can be used to implement saved 
value support. This shows how the tool user can use the preference page to define tool 
specific values. These values can be used to control the logic you implement in your tool.  
1. Add the following preference page plug-in extensions to the plugin.xml file. 

Note:  You can copy these statements from the EDU_plugin.xml page: 
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<!-- Preferences Page1 Extension                           --> 
   <extension 
  point="org.eclipse.ui.preferencePages">  
  <page  
    id="com.ibm.lab.dialogs.prefpage1"  
    name="EDU: Basic Preference Page"  
    class="com.ibm.lab.dialogs.MyBasicPreferencePage">  
  </page>  
  
   </extension>  
<!-- vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv --> 

This extension adds one page to the common preferences dialog available in the workbench. 

2. Save the plugin.xml file to store the preference page definition.  

Step 2: Define a preference page 

You will now implement the preference page defined in the plug-in extension.  

The MyBasicPreferencePage class will inherit the preference page processing 
implemented in PreferencePage as part of the dialog framework. 

The PreferencePage superclass provides a default implementation of using a 
preference store to manage stored values. The controls you add to the property page can be 
initialized with default values and then use customized values obtained from the preference 
store.  

Use of this dialog framework processing requires that you add logic to your preference page 
implementation class.  
 
Note: You can use the PDE Extension page editor to generate the MyBasicPreferencePage class if 
you trigger the wizard using the drop down in the properties page for the class attribute. This is the process 
you followed in the FirstPlugin lab to generate the action class. If you use this approach you can skip 
to step 2. 

 
1. Create a MyBasicPreferencePage class in the com.ibm.lab.dialogs package. This new 

class must extend the class:  

org.eclipse.jface.preference.PreferencePage  
 

and implement the interface: 

IWorkbenchPreferencePage 
 

Select “Inherited abstract methods” (but do not copy the constructors). This will add methods, 
such as the createContents() method, which will be used to customize the user interface 
for the preference page. 

Note: If your class does not have the required methods one or more errors will be generated. If 
you forget to inherit the methods of the superclass you can add them using a context menu 
action available in the Outline view. To quickly add the missing methods select the class in the 
Outline View and use the context menu option Override Methods to open a dialog. This dialog 
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will have already selected the required methods that are missing from your class so you can just 
click OK. 

2. Add a Text field to the MyBasicPreferencePage class. This field will be referenced in 
methods that will be defined later: Any errors will be corrected when you add import statements 
in the next step. 

private org.eclipse.swt.widgets.Text textInfo; 

 
3. Customize the createContents() method so that you have added at least one widget to 

the preference page. Add these import statements to your class: 

import org.eclipse.swt.*; 
import org.eclipse.swt.layout.*; 
import org.eclipse.swt.widgets.*; 

Replace the generated method with the one below to add a text widget: 

protected Control  
  createContents(org.eclipse.swt.widgets.Composite parent) { 
  textInfo = new 
    Text(parent, SWT.SINGLE | SWT.BORDER); 
  textInfo.setText("Text String Value"); 
  GridData data = new  
    GridData(GridData.FILL_HORIZONTAL); 
  textInfo.setLayoutData(data); 
  return textInfo; 
} 

4. Consider adding System.out.println(); statements to selected methods in your 
preference page class to trace data values or method invocation. For example, you could add 
these two statements such as: 

  System.out.println("MBPrefPage: ------> PrefPage init"); 
 
  System.out.println("MBPrefPage: ------> PrefPage createContents"); 

to the init() and the createContents() methods respectively. 

 

5. Test your preference page class. Start the workbench (if required) 
Use the Workbench Window > Preferences menu option to start the preferences dialog. Select 
the entry for your preference page (Lab: Basic Preference Page). You should see the 
following: 
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Figure 4-1 
Basic Preference Panel [dialog_06.tif] 

This is a custom preference page, but the value shown is hard coded (see your 
createContents() method).  

Note: The Restore Defaults, Apply, OK, and Cancel buttons are added automatically, but 
they will not do anything as you have not yet implemented any support for the value 
management life cycle in your property page class. 

Step 3: Adding value management life-cycle support 

The dialog framework for both property pages and preference pages provides hook 
methods that support the life cycle processing for the values that will be shown and saved. 
The hook methods process the following user interactions: 

• Obtain the current values 
• Show default values 
• Apply (save) the values 
• Leave the page with either an OK or Cancel request.  

By implementing the life cycle hook methods you will have a place to add the customized 
logic required to link the controls you created and the preference store that will be used to 
save values. 

In this step you will add the hook methods to your preference page class. 
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1. Copy these methods to the MyBasicPreferencePage class from the helper file 
EDU_MyBasicPreferencePage.jpage: 

• setVisible() 
• performDefaults() 
• performOk() 
• performApply() 
• performCancel() 

Each copied method looks similar to: 

public boolean performCancel() {   
  System.out.println("PropCycle: " +  
    "> in performCancel"); 
  return super.performCancel(); 
} 

This will allow us to follow the user interaction life cycle by reviewing the messages in the 
console. Note that the setVisible() method is triggered as the page opens and when the 
page selected in the preference dialog changes. 

2. Start the test workbench, open the Preferences dialog, and select your preference page. Follow 
this process to trigger the life-cycle methods:  

• Select the Lab: Basic Preference Page (if required) 
• Select the Restore Defaults and Apply push buttons  
• Change current properties page (go to the Info page) and return (this forces the setVisible() method) 
• Select either the OK or Cancel push button 

Review the development workbench console window to see the processing life cycle as depicted 
by any System.out.println() statements you copied or added to the life cycle methods. 
You may want to watch the console as you interact with the preferences dialog. 

Part 2: Using a plug-in to manage and store values 

The best way to add saved value support to the preference page is to ask for help from a 
plug-in class. This requires that you have the right type of plug-in, one that extends the user 
interface support provided by the AbstractUIPlugin. 

If you do not implement a real plug-in class, by subclassing AbstractUIPlugin, the 
workbench platform creates a Default plug-in for your tool. But what you want is a plug-in 
implementation that will provide access to the preference store services provided by the 
AbstractUIPlugin superclass. 

Step 1: Find the current plug-in 

To understand how plug-in processing is provided by the workbench platform, even if you 
do not define your own implementation, you will identify the active plug-in available to the 
property page. 
1. Add the import statement to the MyBasicPreferencePage class and highlighted logic 

shown below to the performDefaults() method: 
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import org.eclipse.core.runtime.*; 
 
protected void performDefaults() { 
  super.performDefaults(); 
    System.out.println("PropCycle: "  
            + "> in performDefaults"); 
    // get active plug-in (default or defined) 
    Plugin myPlugin = 
Platform.getPlugin("com.ibm.lab.dialogs"); 
    System.out.println("MBPrefPage: Current Plug-in: \n\t"  
              + myPlugin.getClass());   
} 

You can use your plug-in id to ask the platform for a handle to the active plug-in. The Plugin 
class will accept any plug-in type (defined or default). Before you use a plug-in you need to 
know what type it is so you know what methods you can use. 

 

2. In the runtime instance of the Workbench, open the preference dialog, select your preference 
page, and then click the Restore Defaults push button. You should see this in the console: 

 
MBPrefPage: Current Plug-in:  
  class com.ibm.lab.DialogsPlugin 

This is because when your PDE project was created a plug-in class was generated for you. If a 
plug-in class was not included in your plug-in definition you would have seen the following: 

MBPrefPage: Current Plug-in:  
  class org.eclipse.core.internal.plugin.DefaultPlugin 

Step 2: Update code to use the Dialog Plug-in class 

The platform plug-in class used in step 1 will not support preference processing. You need 
to have a handle to the DialogsPlugin class to support access to the stored preference 
processing methods provided when the plug-in class was generated using the PDE.  
1. Modify the performDefaults() method in your preference page class so that you use your 

DialogsPlugin class.   
Replace this: 
Plugin myPlugin = Platform.getPlugin("com.ibm.lab.dialogs"); 

With this: 
DialogsPlugin myPlugin = DialogsPlugin.getDefault(); 

 
2. Restart the test workbench to verify that your plug-in class is being used. Open the preference 

dialog, select your preference page, and then click the Restore Defaults push button. You 
should see now see this in the console: 
MBPrefPage: Current Plug-in:  
  class com.ibm.lab.dialogs.DialogsPlugin 

 



Implementing Preference Pages 

EX_Pref.doc    Copyright IBM Corporation 2000, 2002  4-8 

Part 3: Using a Preference Store 

In this exercise you will add logic to store the value shown on the preference page created 
previously. This includes creating a PreferenceStore and then using it to manage default 
values and saved values for a key. These values will be shown on the preference page user 
interface.  

Note: At this point you could skip ahead and try Part 4: Implementing a field editor 
preference page exercise that will let you use the preference store provided by the plug-in 
class you just defined and try the preference page implementation that uses 
FieldEditors to automate the implementation of saved values. You can always return 
here later. 

Step 1: Create a Preference Store 

Implement the hook method doGetPreferenceStore() to support creation of  a 
preference store for this preference page dialog. The Dialog framework processing calls 
this method when you ask for the PreferenceStore using the 
getPreferenceStore() method.  

Your doGetPreferenceStore() implementation will ask the plug-in for a 
PreferenceStore. This PreferenceStore will then become active for the 
preferences dialog.  
1. Add the following import statements to MyBasicPreferencesPage: 

import org.eclipse.jface.preference.*; 
import org.eclipse.ui.plugin.*; 

Add the highlighted logic to the init() method (shown below) in your 
MyBasicPreferencePage class.  

public void init(IWorkbench workbench) { 
    DialogsPlugin myPlugin = DialogsPlugin.getDefault(); 
    setPreferenceStore(myPlugin.getPreferenceStore()); 
  } 

2. Add the lines of code highlighted below to the setVisible() method to request a 
PreferenceStore: 

public void setVisible(boolean visible) { 
 
    super.setVisible(visible); 
  System.out.println( 
      "PropCycle: " + "> in setVisible(" + visible + ")"); 
 
  // get prefStore reference 
  IPreferenceStore myPS = this.getPreferenceStore(); 
    System.out.println( 
      "PropCycle: " 
        + "My PrefStore in setVisible: " 
        + myPS.toString()); 
} 
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The class instance data written as part of the System.out.println() for the myPS 
variable will help you determine if you are using the same instance of a preference store when 
restarting the preference page. 

 
3. Test the property page logic and check the console to see that you have created a preference 

store.  
Note: You have not actually saved the preference value yet. This is done in the next step.  

You should be able to see, in the console, that the same preference store handle is returned 
when you change the focus between your preference page and another preference page. 

You can step through the doGetPreferenceStore() method to see how preference store 
is created the first time and then retrieved as the current store from the dialog (this logic is driven 
by the getPreferenceStore() method in the PreferencePage super class). 

Each time you start the dialog, the same preference store is used, this is implemented 
through the use of the plug-in class (a subclass of AbstractUIPlugin) to access to the 
preference store.  The plug-in class creates the object when required, and keeps a handle to 
the object until the platform is shut down. 

Step 2: Add preference store value management logic 

The preference store is used to store and retrieve values by key. You also have the ability 
to define default values by key for use when no value has been defined (returned when the 
preference store keyed value is null). 

This preference store value management logic will be added to the preference page life 
cycle methods setVisible() and performOk() and the plug-in method 
initializeDefaultPreferences().  

 
1. Begin by using the preference store to define a default value for the key that will be stored. Add 

this method to the DialogsPlugin class: 

protected void initializeDefaultPreferences( 
org.eclipse.jface.preference.IPreferenceStore store) { 
  store.setDefault("text_field_key", "myTextDefaultValue"); 
  System.out.println("set preference defaults"); 
} 

2. The setVisible() method is run when the preference page is about to be shown. Add the 
highlighted code below to the MyBasicPreferencePage setVisible() method.  

public void setVisible(boolean visible) { 
 
  super.setVisible(visible); 
  System.out.println( 
    "PropCycle: " + "> in setVisible(" + visible + ")"); 
 
  // get prefStore reference 
  IPreferenceStore myPS = this.getPreferenceStore(); 
  System.out.println( 
    "PropCycle: " 
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      + "> in setVisible: " 
      + myPS.toString()); 
 
  if (visible) { 
    textInfo.setText( 
   getPreferenceStore().getString("text_field_key")); 
  } 
} 

This will set the text field in the user interface to the value saved in the preference store (or the 
default if no value was defined). 

3. To save the user interface data as a keyed value in the preferences store add the highlighted 
statements to the performOk() method: 

public boolean performOk() { 
  System.out.println("PropCycle: " + "> in performOk"); 
 
  getPreferenceStore().setValue( 
    "text_field_key", textInfo.getText()); 
 
  return super.performOk(); 
} 

4. To restore the default value add the highlighted statements to the performDefaults() 
method: 

protected void performDefaults() { 
  super.performDefaults(); 
 
  System.out.println( 
"PropCycle: " + "> in performDefaults"); 
 
  // get active plug-in (default or defined) 
  Plugin myPlugin =  
Platform.getPlugin("com.ibm.lab.dialogs"); 
  System.out.println("Current Plug-in: \n\t" + 
    myPlugin.getClass()); 
 
  textInfo.setText( 
  getPreferenceStore().getDefaultString("text_field_key")); 
 
} 

5. Test the preference page logic and check the console to see that you have interacted with the 
preference store.  

The user interface text entry value will contain the default value at first (returned when the 
keyed value is null).  

Enter a value and change pages. If you modify the text entry content, but do not use the Apply 
push button, the originally saved (or default) value returns after a page focus change. This is 
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because the setVisible() method loads the value from the preference store each time the 
page is shown. 

Enter a value and then use the Apply push button. You should see the new value return after 
you change the focus between your preference page and the Info property page. The Defaults 
push button will reset the visible value to the assigned default. You still have to use Apply to 
have these default values saved. 

Exit the preferences dialog when testing is complete. 

Part 4: Implementing a field editor preference page 

A field editor preference page automates the process of linking the values obtained from 
visual controls with a keyed value in a preference store. 

Step 1: Add preference page extensions 

The first task is adding another preference page extension. 
1. Add the following preference page plug-in extensions to the plugin.xml file. 

 
Note:  You can copy these statements from scrapbook page EDU_plugin.xml: 

<!-- VVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVV --> 
<!-- Preferences Page2 Extension Field Editor              --> 
<!-- ===================================================== --> 
   <extension 
  point="org.eclipse.ui.preferencePages">  
  <page  
    id="com.ibm.lab.dialogs.fieldPrefpage"  
    name="EDU: Basic Preferences SubPage"  
    class="com.ibm.lab.dialogs.MyFieldEditorPrefPage" 
    category="com.ibm.lab.dialogs.prefpage1">  
  </page>  
   </extension>  
<!-- vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv --> 

This extension adds a sub page to the preferences page you defined earlier.  
 

2. Save the plugin.xml file to store the new preference page definition. 

Step 2: Implement a FieldEditorPreferencePage 

You will now implement a field editor preference page to map to the plug-in extension.  

The MyFieldEditorPrefPage class will inherit the field editor preference page processing 
implemented as part of the dialog framework. 

 
1. Create a MyFieldEditorPrefPage class in the com.ibm.lab.dialogs package. This new class must 

extend org.eclipse.jface.preference.FieldEditorPreferencePage and implement the 
IWorkbenchPreferencePage interface. 

Let the wizard generate the “Inherited abstract methods” but NOT the “Constructors from the 
superclass” (you will supply your own). This will add methods, such as the 
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createContents() method, which will be used to customize the user interface for the 
preference page. 

Note: A compilation error will exist until you create the constructor in the next step. 

 
2. Add the following import statement and constructor to the MyFieldEditorPrefPage class: 

import org.eclipse.jface.preference.*; 
 
public MyFieldEditorPrefPage() { 
  super(GRID); 
  setDescription("My Field Editor Preference Page \n"); 
} 

You can test the page now but it will not have anything but a title. 
 

3. Assign the preference store to the class by adding the highlighted logic to the constructor: 

public MyFieldEditorPrefPage() { 
  super(GRID); 
  setDescription("My Field Editor Preference Page \n"); 
  IPreferenceStore store = 
    DialogsPlugin.getDefault().getPreferenceStore(); 
  setPreferenceStore(store); 
} 

Note: This requires that you have implemented the plug-in class as described in Part 2. Using a 
plug-in to manage and store values. 

Step 3: Add Field Editors to the preference page 

The createFieldEditors() method in the MyFieldEditorPrefPage class is called 
to populate the user interface with the controls you want on your preference page. You 
must customize this method to add the fields. Each field has a type and a key to be used in 
the preference store assigned to the preference page. 

 
1. Review the available field editors by opening up the common super class 

(org.eclipse.jface.preference.FieldEditor). As you can see, there are many types of field editors: 
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Figure 4-2 
Field Editor Hierarchy [dialog_07.tif] 

 
2. Customize the createFieldEditors() method to add field editors to your preference 

page. 

protected void createFieldEditors() { 
 
  // Note: The first String value is the key used in  
  // the preference store and the second String value  
  // is the label displayed in front of the editor. 
 
  ColorFieldEditor colorField = 
      new ColorFieldEditor( 
          "COLOR_KEY", "COLOR_KEY_Label", 
          getFieldEditorParent()); 
 
  BooleanFieldEditor choiceField = 
      new BooleanFieldEditor( 
          "BOOLEAN_KEY", "BOOLEAN_KEY_Label", 
          org.eclipse.swt.SWT.NONE, 
          getFieldEditorParent()); 
 
  FileFieldEditor fileField = 
      new FileFieldEditor( 
          "FILE_KEY", "FILE_KEY_Label", 
          true, 
          getFieldEditorParent()); 
  fileField.setFileExtensions( 
      new String[] { "*.jar", "*.txt", "*.zip" }); 
 
  addField(colorField); 
  addField(choiceField); 
  addField(fileField); 
} 
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Step 4: Testing the field editor preference page 
1. Start the runtime workbench, open a preference dialog, and select your preference page. It 

should look like this: 

 
Figure 4-3 
Customized Field Editor Preference Page [dialog_08.tif] 

 
2. Manipulate the user interface to trigger the life-cycle methods. You can follow this process if 

you want: 

• Select the Lab: Basic Preferences Sub page  
• Manipulate the controls shown to set values  
• Select the OK push button 
• Shutdown the Workbench 
• Find the pref_store.ini file in this directory: 

   …\eclipse\ 
     runtime-workspace\ 
      .metadata\.plugins\com.ibm.lab.dialogs 
 

You should be able to see your field editor values in the file used to store preferences for your 
plug-in. 
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Exercise Activity Review 

The dialog framework for preference page implementation was the focus area for this 
exercise.  

You have worked with the basic functions of the dialog framework for preference pages by 
creating extension definitions for preference pages and defining Java implementations of 
preference pages and implementation of value storage using a preference store. 

During this exercise you have learned how to: 

• Add preference page extensions to a plugin.xml manifest file 
• Create a preference page that could restore values to the user interface from a preference store  
• Implement complete management of a preference store by adding support methods to the 

DialogsPlugin class.  
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Step 1. Define View Extension  
Edit the plugin.xml and add the view extension, this includes a category for the view (how it will be found in 
the Show View dialog) and the view itself. 

1. Edit the plugin.xml file in the com.ibm.lab.resourceview project you imported earlier. 
Select the Extensions tab. You will now specify the information needed for the View extension. 

2. Define the view extension.  

Select the Add… button. Select Generic Wizards > Schema-based Extensions. 
Press Next. Scroll down the list and select the extension point for views, 
org.eclipse.ui.views and Press Finish.  

3. Define a view category. 

Select the org.eclipse.ui.views entry in the extensions list and choose the New > 
Category context menu. Using the Properties view, modify the id for the category to 
be com.ibm.lab.view.category and the name for the category to be Edu: Views. 
The parent category will be blank.  

4. Define the view 

Select the org.eclipse.ui.views entry in the extensions list and choose the New > 
View context menu.  

Using the Property View, specify the following: 

• category of com.ibm.lab.view.category 
• icon of icons\sample.gif 
• id of com.ibm.lab.view.resourceview  
• name of Resource View  

Ignore the class property for now, you will specify a value later. 

5. Save the plugin.xml file. The XML for the new view should look like this in the Source page: 

<extension 
     point="org.eclipse.ui.views"> 
   <category 
        name="EDU: Views" 
        id="com.ibm.lab.resourceview.category"> 
   </category> 
   <view 
        name="Resource View" 
        category="com.ibm.lab.resourceview.Category" 
        class="com.ibm.lab.resourceview.ViewPart1" 
        id="com.ibm.lab.view.resourceview"> 
   </view> 
</extension> 

Step 2. Generate View Part 
The PDE can generate classes for many extension types. You will now use the PDE to generate a class for 
your view part. 
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1. Return to the extensions page of the plugin.xml file and select the Resource View (view) 
entry. Generate the View class using the PDE. 

In the Property View, generate the class by selecting the continuation entry (...) in the 
class field. In the Java Attribute Editor, specify that you want to generate a new Java 
class. The class name is ResourceView and you want to let the wizard open an editor 
on the class after it is created. Leave the source folder and package name at their 
default settings. 

Select Finish to generate the class. 

When complete the wizard will open an editor open on the ResourceView class. The 
wizard generated the required createPartControl() method and a setFocus() 
method.  

2. Add an SWT control to the View’s user interface in the createPartControl() method. Your 
choice of SWT control content. For fun try using the SWT Layouts example view to generate a 
bit of SWT code you can paste into the method. You will have to modify the SWT Layout view 
generated code to use the composite passed to the createPartControl() method instead of 
the shell referenced included in the generated code. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to add the required import 
statement(s).   

Your createPartControl() method should now look something like this (created 
using the FillLayout page in the SWT Layout view): 

public void createPartControl(Composite parent) { 
 RowLayout rowLayout = new RowLayout(); 
 FillLayout fillLayout = new FillLayout (); 
 parent.setLayout (fillLayout); 
 List list0 = new List (parent, SWT.BORDER); 
 list0.setItems (new String [] {"Item 1", "Item 2", "Item 3"}); 
 
 Tree tree1 = new Tree (parent, SWT.BORDER); 
 TreeItem treeItem1 = new TreeItem (tree1, SWT.NONE); 
 treeItem1.setText ("Item1"); 
 TreeItem treeItem2 = new TreeItem (tree1, SWT.NONE); 
 treeItem2.setText ("Item2"); 
 
 Table table2 = new Table (parent, SWT.BORDER); 
 table2.setLinesVisible (true); 
 TableItem tableItem1 = new TableItem (table2, SWT.NONE); 
 tableItem1.setText ("Item1"); 
 TableItem tableItem2 = new TableItem (table2, SWT.NONE); 
 tableItem2.setText ("Item2"); 
} 

Note: Copy the code above from the JPages\Part1_ViewPart.jpage file. 

3. Launch the runtime workbench to test the view user interface.  
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Open the view: Window > Show View > Other…and then select the Resource View 
in the Edu Views category. The view shown will look like this if you used the code 
shown above: 

 
Figure 7-1 
Resource View with SWT-based User Interface  

You now have a class that can be reworked to be a functional View part.  

The SWT controls will be replaced by a viewer created from the reusable JFace 
component defined in a previous exercise (or you can use the JFace component 
solution provided). 

Close the runtime workbench after testing is complete. 

Part 2: Add the JFace Component to the View Part 
The current view just shows the SWT controls you added to test the view. It is time use the JFace 
component to customize the view user interface.  

The JFace component will be added first with a default input value so it can be tested, then the view will be 
customized to obtain the input from a source outside the view.  

Note: If you did not complete the JFace component exercise you will need to load the solution and use that 
code during this exercise. Use the same technique outlined in Exercise 4. Lab Imports but import only the 
project com.ibm.soln.jface from the \PluginSolutions directory. 

Step 1. Add JFace Component to View User Interface 
Begin by adding the viewer in when the view’s user interface is created. This must begin with a modification 
to the plugin.xml to add the JFace component project to the list of required projects, only then can we get 
compile time and runtime visibility to the classes in that project. 

1. Modify the plugin.xml dependencies by adding the com.ibm.lab.jface or 
com.ibm.lab.soln.jface project to the list of required projects. The 
com.ibm.lab.resourceview plugin.xml requires element should look like this when you 
are done: 

   <requires> 
      <import plugin="org.eclipse.core.resources"/> 
      <import plugin="org.eclipse.ui"/> 
      <import plugin="com.ibm.lab.jface"/> 
   </requires> 

2. Modify the plugin.xml runtime definition for the com.ibm.lab.jface project to share the 
runtime code with other plug-ins. Select the jar file name on the runtime page and then select 
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the Export the entire library option. If you are using the com.ibm.lab.soln.jface project 
this has already been done. 

The com.ibm.lab.jface plugin.xml runtime element should look like this when 
you are done: 

   <runtime> 
      <library name="jfaceComponent.jar"> 
         <export name="*"/> 
      </library> 
   </runtime> 

3. Add this field to the ResourceView class definition: 

// JFaceComponent reference for listeners to be defined later 
JFaceComponent jcomp; 

4. Modify the createPartControl() method so that it contains only the following code: 

jcomp = new JFaceComponent(parent); 
jcomp.configureViewer(); 
jcomp.setInput(ViewPlugin.getWorkspace().getRoot()); 

The JFace component constructor will create the viewer using the passed composite 
as the parent, the configure process defines the default content provider and label 
provider, and the workspace root is defined as the input to the viewer.  

Use the Source > Organize Imports option (Ctrl+Shift+O) to revise the import 
statements to match the code.   

That’s all it takes! You will customize this method later to add selection processing. 

5. Launch the runtime workbench to test the new view user interface. The view shown should 
look like this: 

 
Figure 7-2 
Resource View with JFace Component Viewer in the User Interface 

The view displays content based on the identified input, the full workspace root.  

Since the content provider in the JFace component was constructed with a resource 
change listener, the content in the Resource View will change if you add a new project 
to the workspace. 
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Close the runtime workbench after testing is complete. 

Step 2. Customize the View to React to Viewer Selection Changes 
You did this in the JFace component exercise, but this time you will do something a bit more interesting. 
The view part has access to the workbench site, and from there can contribute content to the status bar.  

1. Modify the createPartControl() method in the view part by adding the logic shown below 
after the viewer input has been defined: 

jcomp.addSelectionChangedListener(new ISelectionChangedListener() { 
   public void selectionChanged(SelectionChangedEvent event) { 
      System.out.println(">View hears selection" + event.getSelection()); 
      IStructuredSelection ssel = (IStructuredSelection) event.getSelection(); 
 
      //Get common Workbench status bar 
      IStatusLineManager status = 
        getViewSite().getActionBars().getStatusLineManager(); 
 
      // Push IResource location to status bar  
      if ((ssel != null) && (ssel.getFirstElement() instanceof IResource)) { 
        IResource res = (IResource) ssel.getFirstElement(); 
        status.setMessage(res.getLocation().toString()); 
      } else { 
        status.setMessage(null); 
      } 
      status.update(false); 
   } 
}); 

Note: Copy the code above from the JPage\Part2_JFace_Comp.jpage file. 

Use the Source > Organize Imports option (Ctrl+Shift+O) to revise the import 
statements to match the code.   

2. If you wish to simplify the createPartControl() method logic you can refactor the code. 
Extract a method from the addSelectionChangedListener() logic just added. Name the 
new method processViewerSelection(). This method will be invoked as part of the 
createPartControl() method. 

3. Launch the runtime workbench to test the modified dialog user interface. Select the readme 
folder and then select the context menu Edu: JFace > Edu: Open JFace Dialog. The 
workbench shown should look like this when an element in the view is selected: 


